QTimer.moc missing in Qt 5.2.0 shadow build on Win 7 x64 and VS2013



  • Hi,

    I've got Qt 5.2.0-beta1 building in place OK, but when I try to do a shadow build it fails because qtimer.moc cannot be found.

    The .moc directory of the in place build does have this file and the shadow doesn't. There are other differences as well (e.g. qstatemachine.moc is also missing).

    Also, if I compare the generated Makefile.Debug and Makefile.Release files for corelib from the two areas there are a number of file differences over and above the expected path differences. This suggests there is an issue with shadow building with the beta, however, I'm quite new to Qt so I'm quite prepared to accept I'm doing something wrong.

    Can anyone throw some light on this?

    Thanks.

    Stephen


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    How did you configure Qt to build ?



  • The configure options I used were:

    configure -prefix C:\Qt\5.2.0\Win32 -debug-and-release -platform win32-msvc2013 -opensource -qt-style-windowsxp -qt-style-windows -developer-build -confirm-license -opengl desktop

    I used the same options, sans -prefix, for the in place build which works OK.


  • Lifetime Qt Champion

    Since you configure a developer-build just call configure directly from the directory where you want to have your Qt built and remove prefix
    e.g.

    @cd C:\Qt\5.2.0
    C:\Qt\qt_sources_path\configure -options_you_want
    nmake or jom.exe@

    And you should be good to go



  • Tried that, same result.


  • Lifetime Qt Champion

    I missed the fact that you are using the beta1, you should rather take the latest 5.2 version (at least RC1)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.