[solved] Fail: Mavericks & Qt 5.2rc - could not find or load the Qt platform plugin "cocoa"



  • I managed to install Qt 5.2rc on my Mac OSX 10.9 Mavericks.
    My application code compiles fine..

    But when I try to run it from QtCreator I get:

    "This application failed to start because it could not find or load the Qt platform plugin "cocoa"
    "Reinstalling the application may fix this problem.
    The program has unexpectedly finished."

    I re-installed Qt 5.2rc but no change..

    I have xcode verison 5.0.2 and installed the command line tools, prior to installing Qt 5.2rc.

    Any ideas?



  • ha sorry.. this seems fixed...
    I rebuilt the app, and it didn't delete the old .app file..

    Manually deleting and rebuilding was the solution here.


  • Lifetime Qt Champion

    Hi,

    Nice you found out !

    Can you also update your thread title prepending [solved] ? So other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.