[solved] Qt on Windows8.1 no freakin way to get it run



  • Hi,

    i dont know anymore what to do to get Qt run on my Laptop. I tried so many instructions and whatever but always there is something that says NO. Its running but he just wont accept my "Kit-things..." (dont understand why its not selfinstalled from beginning anythin we need to get it started, but OK !)...there is always a red screamer on my compiler etc and there is NOTHING on the internet or somewhere else that describes a solution. i just dont get it...why is it like this. it worked before on my windows 7 system just fine, but now, again, something is not working and so on...always this big suffering before Qt runs is just exhausting. install this install that then maybe it will run. i hope there is somebody out there who knows what to do. maybe its because of my msvc version. or whatever i just dont know anymore after three days.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What version of Qt did you try to install ? What version of Visual Studio do you have ? If you want to use the MSVC versions, you should better install Visual Studio first. One very important thing, you have to match exactly the Visual Studio Version with the Qt version you want to install or build Qt yourself.

    Don't want the hassle of Visual Studio ? Use the MinGW package which comes with it's own compiler (no It cannot be done for Visual Studio, it's a product from Microsoft that can only be installed through them) Visual Studio Express can be used but the VS addin can't because of the plugin restriction in the free edition.

    Hope it helps



  • nooooooo way... i ve used the wrong qt version(s) the whole time.

    vs instead of mingw...just looked for the "x64". now it runs with the mingw32 version and the right compiler.

    big sorry and thanks a lot :)


  • Lifetime Qt Champion

    No worries, that can happen. You're welcome !

    There's no MinGW 64bit package but you can build it yourself if you really need it (you would need to get a 64 MinGW though)

    IIRC, there are some unofficial package including the 64bit, you'll have to search through the forum a bit.

    Since everything is ok now, please update the thread title prepending [solved] so other forum users may know a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.