Qt 5.2 Beta1 -> shadow buildling QtWebKit doesn't honor prefix?



  • I am doing a build off of a git repo on Windows using msvc2010

    After a run of configure and jom to build, it appears that qtwebkit was not actually built. I based this on nothing in my output folder (specified w/ --prefix to configure). I then tried following "Building-Qt-5-from-Git":http://qt-project.org/wiki/Building-Qt-5-from-Git which points to "BuildingQtOnWindows":http://trac.webkit.org/wiki/BuildingQtOnWindows which tells me to run perl Tools\Scripts\build-webkit --qt --release. I made sure to have the correct files in the path and this seems to have built but nothing got installed. I found files under the actual git repo (which is not what I wanted). I also found a bunch of errors in the config.log for qtwebkit about not finding include files.

    I guess my simple question is does qtwebkit "just build" in qt 5.2 with a shadow build + prefix? Do I need to run the perl script or will the qt5 "configure" + "make" + "make install" be enough (it didn't do it for me and the docs have me confused). Assuming the answer to those is yes ... any guess as to why it didn't build?

    Thanks



  • As a note, I have gotten past this now. I believe I had ommitted the -icu (along with the -I & -L to point to my local builds of ICU as they were not installed on my system). I has been a while, but if I recall that was the root of the issue. I also found that I had to have ICU 5.x. I tried to build against ICU 4.4 and I got errors when launching lrelease. There were some articles I found on this but I was willing to move to 5.x of ICU so I did


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.