MacOS X Mavericks/Xcode 5 Qt 4.8.5 can't find Make



  • As usual, every time I get updates from XCode, I rebuild Qt from source code, right now I'm using Qt 4.8.5

    Now, the problem is that, with this update to XCode 5, I had to install the command line tools separate from XCode, as I see Apple really makes an effort to kick you in the b*lls so you either use xcode or nothing at all.

    After installing the command line tools, and testing make, cc, etc. everything worked fine, but now that I try to run the configure command to build Qt, I get an error that the configure script can't find make! I setted the environment variables by hand, and still nothing, but other tools I use are building ok.

    The following configure command is the one I've used since 4.8.2 and I know it works.

    @
    MacBook-Pro:4.8.5 raul$ ./configure -platform macx-llvm -debug-and-release -fast -silent -optimized-qmake -opensource -largefile -plugin-sql-sqlite -no-qt3support -xmlpatterns -multimedia -audio-backend -svg -webkit -javascript-jit -script -scripttools -declarative -declarative-debug -qt-zlib -qt-libtiff -qt-libpng -qt-libmng -qt-libjpeg -openssl -I /usr/include -L /usr/lib
    You don't seem to have 'make' or 'gmake' in your PATH.
    Cannot proceed.
    @

    Has anyone seen this before? thanks!


  • Lifetime Qt Champion

    Hi,

    what does

    @which make@

    return in your console ?



  • Hi SGaist, thanks for the reply,

    It answers /usr/bin/make


  • Lifetime Qt Champion

    Then it's getting stranger, which exact version of Xcode are you using ?



  • I'm using XCode 5.0.2


  • Lifetime Qt Champion

    What does happen if you just call configure without any options ?



  • I'm sorry I haven't posted, as the macbook is at my house and at work I use a Win 7 box.

    It turned out that because of some weird character in the file I had that issue, even though I downloaded the source from the tar.gz package, still had bad char issues, I just ran a perl command to remove all odd characters and it was able to find make.

    Now the issue is that the build breaks, first I get a zillion warnings because it says that the Mac OS X version is not supported, and then it breaks building webkit, after I tried using the --no-webkit flag, now it breaks in phonon, the problem is that I use webkit in my application, so I guess that 4.8.5 is just not build for newer OS and I don't even know if there's gonna be a patch to be able to build it in Mavericks, as everything is moving to Qt 5, but still I can't hold my development and I don't have the time to migrate all of my codebase to Qt5, and also the mac extras I make use of, still break in Qt 5.2 beta1, and from what I see in JIRA, basic stuff like mac unified toolbar is not likely yet to appear even in the final 5.2 version, and that's a BIG hold up for moving to Qt 5.


  • Moderators

    Don't worry, Qt 4.8.6 is planned, and has already entered some initial release procedures. It should be out in a few weeks' time.



  • Would it be possible to get a pre-release of this (with all caveats assumed)? Really need this for Mac testing asap... :-)


  • Lifetime Qt Champion

    You can build it from git so you'll be "bleeding edge"



  • My apologies...I don't know how to navigate the git site...can you provide an explicit path?


  • Lifetime Qt Champion

    No need to navigate it just do:

    @ git clone git://gitorious.org/qt/qt.git@

    grab a [insert name of favorite hot beverage] and you should be good to go



  • Does this give me the sources for 4.8.6? I would have thought it was 5.x...


  • Lifetime Qt Champion

    Yes it does.

    Qt 5 can be found in git://gitorious.org/qt/qt5.git



  • To Raul - if you're interested, there's a discussion of this phonon build failure over in this thread:

    https://qt-project.org/forums/viewthread/35625/
    

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.