Qt Creator 2.8.1 doesn't see samsung galaxy s4 on Ubuntu 13.10



  • Hello!

    Please, help with the following.
    I'm trying to run example app with Qt 5.1.1 & Qt Creator 2.8.1 OS: (Ubuntu 13.10) on my Samsung galaxy s4 with Android 4.3.
    But get error from Qt Creator: "cannot deploy:no device or emulator found for your package".
    I tried using an emulator directly running it from SDK manager too, but got the same error.

    adb sees devices:
    "4d00050f7aa540c3 device // - samsung s4
    emulator-5554 device"

    I activated usb debugging on the telephone through developer options.
    I also added udev rule and now when device's plugged in, file with mode 0777 is created in /dev/bus/usb. In file manager i can see the telephone and can enter its storages. I also get request to accept RSA key and click OK.

    Project settings:

    • API level 14 (also tried latest versions);
    • gcc 4.6 (android for armv7);

    If I missed some info, please ask. Thanks!



  • Hello again!

    I was lucky to solve question: i'm using 64-bit version of Ubuntu, and installed appropriate android SDK Tools. But when i began to update it with "android" command line tool, it downloaded 32-bit versions of build-tools and platform-tools.

    Therefore i added 32-bit architecture:

    @sudo apt-get install libc6-i386 lib32stdc++6 lib32gcc1 lib32ncurses5
    sudo apt-get install lib32z1@

    Then i got some errors from ant and downgraded build-tools from 19.0 to 18.1.1 with "android" cmd tool.

    And it works!



  • This post is deleted!

Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.