[solved] DLL Qt5Cored not Found.

  • Hello All,

    I was hoping someone could lend me a hand with this problem I am having.

    Goal #1: I am attempting to create an adaptable developement enviroment for work, so I would like to avoid directly adding paths into the PATH variable for the system.
    Goal #2: I want to avoid copying any dlls into the program folder, I would rather acess them through the added enviromental paths in Visual Studio.

    So with the Qt VS plugin I have the path for my QT folder set correctly to: C:\Qt\Qt5.1.1\5.1.1\msvc2012_64_opengl.
    My project has this set as its QT version( I have QT4 as well, but the 5.1.1 is selected in the plugin)
    Now using the default macro in VS for $(QTDIR) allows me to find both the .h files compiling, and the .lib files for linking, but it never finds the QT Dlls at run-time.
    The QT plugin appears to auto-add "PATH=$(QTDIR)\bin;..." to the start of my enviroment settings in configuration/debugging which is exactly what I want, but it doesn't seem able to find anything at run-time.

    Does anyone have any experience with this problem, or can someone help point me in the right direction?

    Just to confirm, I have found that if I copy the required QT5 dlls into the executable folder the application runs fine, but I want to avoid having to do this.

    Windows 7 64-bit
    Visual Studio C++ 2012 Professional
    Qt 5.1.1 64-bit pre-built with opengl.
    Qt Vs plugin 1.2.2

  • Update: Problem solved.

    In the end it had nothing to do with QT, I am also using MKL in the project, and its DLL path to MKL was within the "$(LocalDebuggerEnviroment)" Macro that had an error in it, and was then destroying my path at run-time. I changed over the following line to call MKL wiht a MKL Macro and everything works fine now. I was mislead into thinking the problem was QT by Qt5Cored.dll being the file that wasn't found.

    Thanks in any case.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Glad you found and thanks for sharing !

    Can you also update the thread title prepending [solved] ? So other forum users may know a solution has been found :)

Log in to reply