[Solved] Building QT 5.2 from GIT/stable branch



  • Hi All,

    (This problem was solved, but has reappeared the last week or so. Currently, I can only use IOS builds by building in the source folder and create kit in QT Creator from there.)

    I have fetched the latest QT source, and initialized repository without webkit. I would like to compile for Desktop, iPhone simulator and iPhone device. I do off course build in clean build folders.

    I configure the iPhone device build as:

    qtrepotools/bin/qt5_tool -c
    ./configure -xplatform macx-ios-clang -developer-build -confirm-license -opensource -nomake tests -prefix /Users/sverre/Tools/Qt/5.2.0/ios
    make -j 6

    When I attempt to build , I get following error:
    "The directory /Users/sverre/cpp/Qt/Qt-5.2/qt5/qtdeclarative/tools/qmljs does not contain an Xcode project."

    If I go to that folder and create the xcode project with qmake, I can complete the compile, but when I execute "make install", I get:


    PhaseScriptExecution Project\ Copy .obj/qml.build/Debug-iphoneos/qml.build/Script-9C316F444A62BF296E3E1F25.sh
    cd /Users/sverre/cpp/Qt/Qt-5.2/qt5/qtdeclarative/tools/qml
    /bin/sh -c /Users/sverre/cpp/Qt/Qt-5.2/qt5/qtdeclarative/tools/qml/.obj/qml.build/Debug-iphoneos/qml.build/Script-9C316F444A62BF296E3E1F25.sh
    cp: /Users/sverre/cpp/Qt/Qt-5.2/qt5/qtdeclarative/tools/qml/Debug-iphoneos/qml.app/qml.app/qml.app: directory causes a cycle
    Command /bin/sh failed with exit code 1

    Has anyone seen this, and is there a quickfix so I can compile and install QT for the iPhone device ?

    I have the same problem when compiling for iPhone simulator SDK

    Builds for desktop compiles without problems.

    I build on a Mac, OS X 10.9

    Xcode 5.0.2
    Build version 5A3005
    OS X SDKs:
    OS X 10.8 -sdk macosx10.8
    OS X 10.9 -sdk macosx10.9

    iOS SDKs:
    iOS 7.0 -sdk iphoneos7.0

    iOS Simulator SDKs:
    Simulator - iOS 7.0 -sdk iphonesimulator7.0

    br,
    /Sverre Eplov


  • Lifetime Qt Champion

    Hi,

    Does is also fails if you use this

    @../qt5/configure -xplatform macx-ios-clang -developer-build -confirm-license -opensource -nomake tests@

    from an out of source folder ?



  • Hi,

    It fails the same way with missing qmljs xcode project, but by manually creating the qmljs.xcodeproj in the out of source folder, I can get it to compile. I will give it a go tomorrow and see, if I can deploy to my iPhone using the latest 5.2 stable branch.

    thanks for the tip ;)

    br,
    /Sverre



  • Hi,

    updated qt5/stable branch to SHA fc6f18a589d54f4dc7a4f75131e61e29b8e8cb31 today, the problem has been fixed there.

    So back to normal compiles, and things are really beginning to look good developing IOS apps with QT5 ;)

    br,
    /Sverre


  • Lifetime Qt Champion

    Great !

    Indeed, it's getting in a pretty good shape :)

    Since you have it working, please update the thread title prepending [solved] so other forum users may know a solution has been found :)



  • It is a good idea to clean out /tmp folder when building on OS X - an old build was interfering when doing "make install"


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.