[SOLVED] missing plugin for qtLocation



  • qt 5.2.0-beta installed from the binary installer
    QtLocation installed from the git repository :

    QtLocation seems to install alright:
    Users/clogwog/Qt5.2.0/5.2.0-beta1/ios_armv7/mkspecs/modules /qt_plugin_qtposition_cl.pri
    contains:
    @QT_PLUGIN.qtposition_cl.TYPE = position
    QT_PLUGIN.qtposition_cl.CLASS_NAME = QGeoPositionInfoSourceFactoryCL@

    added
    @QT += positioning
    LIBS += -framework CoreLocation @

    to my .pro file , but when i ask for the available providers (on the real ios device):
    qDebug() << QGeoPositionInfoSource::availableSources();

    it returns an empty list.

    any tips/pointers on how can i debug where the plugin/installation on my machine is at, and why the list is empty ?


  • Moderators

    CuteiOS already "answered":http://qt-project.org/forums/viewthread/34436/#150261 this in your other thread.



  • no i (also) get this problem with the latest dev version of qtlocation that is supposed to work. (they are only having OS X testing issues, not ios)

    i started investigating more on what is installed after the "make install" on qtlocation , and as described above it looks like the plugin for QGeoPositionInfoSourceFactoryCL (which uses the ios CoreLocation framework) is there .

    even though it seems to be installed, it doesn't show up in the factory.

    my question here relates to how qt handles the plugins, i have tried to follow the source code, but the factories use a lot of macro's so i'm getting lost on what it uses to see what is installed.

    any help regarding the qt plugin framework would be appreciated.



  • iv'e given up on getting QtLocation to work for now, i got around it by making a native xcode project that collects the lat/lon and linking it back to my qt application.

    a few interesting things that i had to solve there as well, but at least it is working now. if anyone else needs to do similar let me know and i'll share the xcode project.

    i'll mark this as solved even though the plugin "corelocation" doesn't load with the current git source of QtLocation on my machines.

    i don't know enough about the plugin system to know if this a bug, or a problem on my setup.



  • @clogwog
    Would you mind sharing your XCode project?

    --Sam


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.