Qt creator does not get a good build config



  • What's wrong with QtCreator?? Can't it just get a path and work on it?

    I have just reinstalled my Windows 7 64-bit OS a week ago, so I had to reinstall QtCreator. I used the online installer and during the install it all goes fine, but then comes troubles. When I tried to configure a Qt version and compiler it would never get it the right way. I'm trying to use a mingw32 and mingw64 Qt build.
    The first time I set up the compilers, it got them correctly, but when I set the Qt version it would say "no qmlscene installed" and "no qmlview installed". And I was like "what?, they're right there in their folders!!!!!!!!!!!". OK then, the installation might had some issues that I wasn't aware of, so going to reinstall QtCreator.
    Uninstalling all Qt things, deleting remaining files and reinstalling (again 1) QtCreator. Now the good news is: Qt versions are correctly recognized but when I open the "Tools > Options" window QtCreator complains about a missing DLL, libwinpthread-1.dll. I thought it was quite not a big deal since the rest of QtCreator was working, but when I tried to compile a well known to work project that I had Qt complained with "Unknown module(s) in QT: gui core". Again, "what??? they're right there in their folders, just where they're supposed to be!!!!!!!!!!!". Dammit, another reinstall is going to happen.
    So, uninstalling again and deleting configuration files and anything remaining of Qt, and reinstalling QtCreator (again 2). Another installation gone without any issues during the install process, but troubles still won't go away. QtCreator no longer complies about the missing libwinpthread-1.dll, but now it wouldn't recognize not any Qt version. I have unpacked the original mingw32 and mingw64 builds and I run the qtbinpatcher.exe included, it goes fine, but when I add the Qt version in QtCreator it would say "qmake does not exist or it's not an executable", for both mingw32 and 64 builds. This time the issue is even more stranger since I manually ran a cmd prompt session and run "C:\Qt\5.1.1\mingw32\bin\qmake.exe -v" and I got a proper output:
    @C:\Users\T3STY>C:\Qt\5.1.1\mingw32\bin\qmake.exe -v
    QMake version 3.0
    Using Qt version 5.1.1 in C:\Qt\5.1.1\mingw32\lib@
    Again.. uninstalling..... reinstalling (again 3) and I am right now sitting in front of a clean-clean QtCreator installation. Please guys, QtCreator is driving me crazy, and I don't know what to do. Can anyone tell me what do I do wrong? It looks to me like I'm doing the very same steps over and over, but QtCreator will always complain about a different thing, not even once would give me the same error. Also, if any Qt developers are around reading this: please, make QtCreator easier to configure!!! It's unbelievable that I have to use a qtbinpatcher thing to get a "working" qt version while all I should do is copy-paste a damm folder inside any Qt installation subfolder (like "C:\Qt\Versions\I_put_my_folder_here" ).


  • Moderators

    What are you installing?
    Qt creator only?
    Or the whole sdk?
    When installing the whole SDK from "here":http://download.qt-project.org/official_releases/online_installers/1.4/qt-windows-opensource-1.4.0-2-x86-online.exe you might have to check of the MinGW Qt lib version to install and also you to select the MinGW compiler suite.



  • QtCreator only. I'm not interested in the MinGW build provided during the install process, I have downloaded my own builds from here:
    http://sourceforge.net/projects/mingwbuilds/files/external-binary-packages/Qt-Builds/
    (I have the first two packages, qt 5.1.1 x32 and x64 with opengl).

    Right now though I'm reinstalling QtCreator with the mingw build provided with the installer. I hope at least this one works... but it's taking ages to download at 130KB/s...


  • Moderators

    Well, it is certainly fine to install some other unofficial builds, but how should someone know this.
    Those builds come with Qt creator versions. I would expect that they are at least consistent as long as you do not want to combine with something else.



  • My issue was that I needed a free cross platform 64-bit compiler to use with QtCreator and since Qt installer does not provide one I have downloaded that version. But anyway, that's not the point.
    The point is that QtCreator is messing up things with no reason. In any application, if you repeat the very same steps over and over, they should give you the same results. In QtCreator I'm always getting a different error that I can't understand how to fix.

    Here, I have just installed the mingw32 build provided in the Qt online installer. I have just took the very same project that I know it was working fine last time, I have deleted the .pro.user configuration (to start as it was brand-new project) and tried to compile with such mingw32 buiild. The result:
    @C:\Users\T3STY\Documents\Qt\Projects\qcp_test1\qcustomplot.h:36: error: QWidget: No such file or directory
    #include <QWidget>
    ^@
    It cannot find the QWidget library... wow... that's great. How come could this happen?? I mean, aren't at least the official builds supposed to be working on first install??

    EDIT
    I'd like to point out that when uninstalling I also deleted the configuration files left in C:\Users\T3STY\AppData\Roaming\QtProject but this doesn't change a thing.
    BTW, creating a new empty project and coding a simple QApplication with a simple QWidget window gives the same result.



  • I have also just noted that Qt won't save the compiler ABI configuration. I explicitly set the x64 compiler to be for 64-bit, but on restart it gets back to default (32-bit).



  • Guys, no one else has any ideas? I reinstalled QtCreator about 10 times now and I'm still stuck with QtCreator not working properly...



  • At last, I managed to get it to work... I didn't use any particular steps, I just kept on reinstalling and configuring compilers and Qt versions.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.