Debugger hangs on breakpoint (near QSGRenderThread)



  • Hi,

    Originally, I posted this to the qt-creator mailing list: "Debugger hangs on breakpoint (near QSGRenderThread)":http://lists.qt-project.org/pipermail/qt-creator/2013-October/002839.html
    I haven't received any responses, so I decided to re-post it here trying to reach a wider community.

    I'm using Qt Creator 3.0.81 (Qt 5.2.0 64-bit) on Linux, built on October 26 from the source code pulled from the Git repository. It's debug/development build and I'm using two separate copies of the build: one to develop, the other to lauch and debug a plugin.

    While debugging some plugins and I've noticed that the debugging session freezes once the execution reaches some of breakpoints. It happens fairly often, but I haven't noticed the exact pattern of what kind of breakpoints actually make the debugger freeze.

    For example, I placed breakpoint in the CMakeProjectManager plugin's CMakeBuildConfigurationFcatory::availaleBuilds() method, then:

    • the execution stops at it, then 1-5 seconds later
    • the stacktrace refreshes view and displays completely unrelated,
    • the step over/in/out buttons get disabled,
    • the debugger is not responding on stepping,
    • the only buttons that are active are pause and stop.

    Here are three screenshots to show what's going on during the sequence above:

    • Qt Creator 1: breakpoint vs stacktrace in different thread

    !http://imageshack.com/a/img577/6858/ccqe.png(Qt Creator 1: breakpoint vs stacktrace in different thread)!

    • Qt Creator 2: added breakpoint vs stacktrace & stop requested

    !http://imageshack.com/a/img5/5714/kdn7.png(Qt Creator 2: added breakpoint vs stacktrace & stop requested)!

    • Qt Creator 3: added breakpoint vs stacktrace & Attempting to interrupt

    !http://imageshack.com/a/img850/5031/9wvl.png(Qt Creator 3: added breakpoint vs stacktrace & Attempting to interrupt)!

    Interestingly, every time it happens, the view title bar displays QSGRenderThread and "Running" next to it.

    If I hit the blue pause button, it changes to "Stop requested" and eventually it shows "Attempting to interrupt" which hangs forever.

    The only thing I can do is to abort debugging and restart it.

    I noticed similar issue while debugging other plugins like the GenericProjectManager and others.

    I wonder, is this something known?
    Do I need to tweak the Qt Creator/GDB debugger settings in some way?
    Does it look like a bug and shall I report?

    Best regards,

    Mateusz Loskot, http://mateusz.loskot.net



  • FYI, this problem has been solved with "André Pönitz' diagnosis":http://lists.qt-project.org/pipermail/qt-creator/2013-October/002844.html of unclean build.

    Quick tests prove that after switching to branch 3.0 and clean rebuild all works well, but I'll wait a bit and continue testing before I mark this topic as solved.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.