Qt 5.1.1. Cross compilation on ARM920T (ARMv4t) : libqxcb.so missing



  • Hello.
    A while ago I succeeded in compiling Qt 4.8.2 (even in debug mode) but I had an issue. Any simple project crashed on the following method with a SEGFAULT exception :
    @
    QBasicAtomicInt::ref().
    @

    Anyway, I decided to start again with Qt 5.1.1. But when I compile it there is an error about a library missing : libqxcb.so.

    @
    cannot find : -lqxcb
    @

    From what I understood, this library deals with an abstraction layer to handle X11 communication.

    I thought that this library was systematically shipped with Qt sources but I can't find it.
    Where am I supposed to find this library ?
    /

    This is additional information.

    • Kernel version : Linux 2.6.32.2

    • Compiler : GCC 4.4.3 (arm-none--linux-gnueabi)

    • Glibc : 2.9

    • GNU BinUtils : 2.20

    /

    I'm sorry if there are any information missing but please ask me.

    Any help would be much appreciated.
    Thank you.


  • Lifetime Qt Champion

    Hi,

    IIRC, you might need to pass -qt-xcb when configuring

    Hope it helps



  • I realized that I would not need this library if I don't use X11. Otherwise I saw that I would need to install libxcb development libraries for ARM processor.

    Am I write ?

    I would like to install Qt5 on an embeded system. Is it possible to run one application in an standalone mode as with the previous versions of Qt ?

    I already tried to compile Qt5 without xcb support and I run into this issue.

    @
    /opt/FriendlyARM/toolschain/4.4.3/bin/.arm-none-linux-gnueabi-ld: warning: canno
    t find entry symbol _start; defaulting to 0000a930
    .obj/debug-shared/moc.o: In function T.1315': moc.cpp:(.text+0x19a8): undefined reference tooperator delete'
    moc.cpp:(.text+0x1a94): undefined reference to operator new[](unsigned int)' .obj/debug-shared/moc.o: In functionMoc::parseFunctionArguments(FunctionDef*)'
    :
    moc.cpp:(.text+0x2614): undefined reference to operator new(unsigned int)' moc.cpp:(.text+0x27f0): undefined reference tooperator new(unsigned int)'
    moc.cpp:(.text+0x2990): undefined reference to operator delete(void*)' .obj/debug-shared/moc.o: In functionT.1312':
    moc.cpp:(.text+0x3c48): undefined reference to operator new(unsigned int)' moc.cpp:(.text+0x3e58): undefined reference tooperator new(unsigned int)'
    .obj/debug-shared/moc.o: In function Moc::checkProperties(ClassDef*)': moc.cpp:(.text+0x4138): undefined reference tooperator new(unsigned int)'
    .obj/debug-shared/moc.o: In function Moc::parseSignals(ClassDef*)': moc.cpp:(.text+0x57e8): undefined reference tooperator new(unsigned int)'
    moc.cpp:(.text+0x59a4): undefined reference to `operator new(unsigned int)'
    @

    Thank you for you help.


  • Lifetime Qt Champion

    You're right, but IIRC, you have also xcb provided with the source of Qt.

    Yes, it's still possible using linuxfb, EGL etc...

    Are you sure your arm toolchain is recent enough to build Qt 5?



  • I don't know it's recent enough or even if it's a good toolchain because it's provided with my development board. At least I can compile my programs without any issue but these are just daemons (no graphic).

    Anyway, I realized that I didn't realy need to have a dedicate board with a dispaly so I switched to Android which is enough for my application.

    The last time I tried to run Qt was more than 1 year ago and I gave up because of an unkown and undocumented error.
    We'll see if I'll make a new try later ...

    Thank you.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.