Qt 5.2 Failure [INSTALL_FAILED_OLDER_SDK]



  • Hello, I have the following message when trying to compile my test environment.

    d:\android\android-sdk-windows\platform-tools>cmd
    Microsoft Windows [versão 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. Todos os direitos reservados.

    d:\android\android-sdk-windows\platform-tools>adb install C:\qt\projects\build-u
    ntitled7-Android_for_armeabi_GCC_4_7_Qt_5_2_0-Release\android\bin\QtApp-debug.ap
    k
    1693 KB/s (6398564 bytes in 3.689s)
    pkg: /data/local/tmp/QtApp-debug.apk
    Failure [INSTALL_FAILED_OLDER_SDK]

    d:\android\android-sdk-windows\platform-tools>

    With qtnecessitas work very well, but not with Qt5.2.

    I did something wrong, is some API was abandoned?

    Note:
    Android 2.2.2
    API: 7 or 8



  • Qt5 and most likely also Qt5.2 need minimum api level 9 which equals android 2.3



  • Wow, I have to explain to my clients that I am a slave to Qtnecessitas. until their devices break.

    What stuck Qt

    Would anyone have any other alternative?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.