Please nominate your Qt Champions for 2021!

Ubuntu: Qt Multimedia 5 upgrade to ubuntu 13.04 from ubuntu 13.10. No sound.

  • I have an application that use Qt Multimedia on ubuntu when I upgraded it to ubuntu 13.10 that application gave this error end no sound output was provided:

    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer"

    I have solved that issue so:

    @sudo apt-get install libqt5multimedia5-plugins@

    Best Regards

  • Ran into a similar issue today when compiling Composer, from the Performous project. Thanks a lot for posting the solution.

  • Hello,
    Just for any developer finding this topic on the internet, I will update some info about this multimedia plugin.

    I am working with Qt5.5.1 on Ubuntu16.04. We must read .avi videos in our project so we developed with QMediaPlayer.

    After succeeding on our development computer, we tried to create a "deployment". Witch was great on Linux was that all Qt5 libs were installed by default. We verified that gstreamer0.10* was also installed.
    Our software was running without issue but we broke into this error :
    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer" , and the video does not play.

    The hint from @willypuzzle, installing multimedia plugins, saved my day. All is running perfectly now.
    Hope this can help other people too.

    Cheers, Fabien.

Log in to reply