[Solved] QtBase Module (5.2 alpha) does not compile on Windows



  • I'm getting following error while I try to compile Qt 5.2 (only QtBase Module) . What I'm I missing here? Include path or something?

    bq. qtextcodec.cpp
    ....\corelib\codecs\qtextcodec.cpp(55) : fatal error C1083: Cannot open include
    file: 'private/qcoreglobaldata_p.h': No such file or directory


  • Moderators

    Make sure you are using the zip package on Windows, not the tarball.

    Also, please try out with newer source code, as the code has moved on since the alpha (beta binary packages are already available, although not "officially").



  • Thank You! My bad, I thought tarball will save some bandwidth. :D



  • will qt 5.2 release with msvc2012 x86 binary too? I can't find the angle build against 2012(x86) libraries but only x64


  • Moderators

    I don't know, Digia plus a few good people from outside are responsible for providing Qt builds. I usually build Qt myself, so I'm not that interested.

    You can ask on the mailing list, or search the archives, IIRC this topic has sprung up a few times already.



  • Ill wait one more day and see. As you pointed out, it doesn't matter. I'll compile it my self if they don't provide binaries. I did compile 5.1 alpha version my self but It took one night on my desktop. So, compiling whole framework is last option to me :) Thank you!


  • Moderators

    I'm happy to help :)

    I'm not a Windows person, but I think you can pass -mp to configure and then it will use all the CPU cores you have. On Linux and Mac the same is done by passing -j to make. If you have a multicore CPU, this is really a good idea: with 9 running jobs (4 core CPU with HyperThreading), Qt compiles in about 20 minutes.



  • Thank you! Ill try "-mp" option. I have four-core CPU. I tried jom but It didn't work out well.


  • Moderators

    You can also pass -skip webkit if you don't need QtWebKit: this saves a lot of time. Plus the general stuff:
    @
    -nomake tests -nomake examples
    @



  • I did skip QtWebKit. My desktop memory was just 2 GB. Maybe that is the bottleneck. lets see this time with 6GB :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.