Qt World Summit: Submit your Presentation

Weird Library path problems with QtCreator 2.8.1 and Qt 5.1.1 - maybe caused by 'run settings' environment bug?

  • I've upgraded to Qt 5.11 from 4.8 and am having major problems with running compiled programs from inside Qt Creator which I never had before. In Windows 7 both gui and console programs fail immediately because they can't find the needed dll's. If I put the following dll's inside the debug directory the programs will start up fine:
    Qt5Cored, libwinpthread-1, libstdc++6, icuuc51, icuin51 and icudt51. Even stranger is that after the program comes up and finds those dll's in it's local directory, the program can now find the other dll's automatically that are located in C:\Qt\Qt5.1.1\5.1.1\mingw48_32\bin. I have verified that the running program can now find the Qt system dll's by writing a demo program with network functions and also loading in various Qt dll's using the Qlibrary functions.

    The only other thing I can find that is strange is that I do not have the ability to check one of the Run "environments' in the Run "settings" menu. I can see and alter all the settings for 'build', 'system' and 'clean', but I can't check any of them to use like I could in version 4.8.

    The path's specified in the windows environment seems to be find, but have not effect in fixing the problems. I suspect that perhaps the problem may be caused by my inability to select the environment in the run settings menu.

    I have removed Qt 5.1.1 and re-installed it with no change, I was using previously a version of necessiatias but I've taken it off. Any ideas anyone? I would really like version 5.1.1 to work for me and not have to go back to the old version 4.

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you only change the Qt version for your project ? If so you can try the following: remove the yourproject.pro.user from your project folder and reopen your project, this will set things up again and you should get your path right.

    Hope it helps

Log in to reply