LinuxFB as display platform doesn't work for Qt v5.1.1



  • I'm compiling Qt v5.1.1 for Zynq embedded system (ARM and FPGA) with these arguments provided to "configure" script:

    @./configure
    -opensource
    -confirm-license
    -arch arm
    -xplatform linux-arm-gnueabi-g++
    -qpa linuxfb
    -gui
    -force-pkg-config
    -qt-zlib
    -qt-libpng
    -qt-libjpeg
    -no-sse2
    -no-sse3
    -no-ssse3
    -no-sse4.1
    -no-sse4.2
    -no-avx
    -no-sql-db2
    -no-sql-ibase
    -no-sql-mysql
    -no-sql-oci
    -no-sql-odbc
    -no-sql-psql
    -no-sql-sqlite
    -no-sql-sqlite2
    -no-sql-sqlite_symbian
    -no-sql-tds
    -no-audio-backend
    -no-gtkstyle
    -no-cups
    -no-dbus
    -no-icu
    -no-iconv
    -no-glib
    -no-openssl
    -no-pch
    -no-opengl
    -no-xcb
    -no-kms
    -no-eglfs
    -no-directfb
    -nomake examples
    -nomake tests
    -prefix /opt/qt@

    After the compilation I build a few examples manually and am able to run them on the target, but when I do that two problems occur:

    1. First problem is same as described in "this question":http://qt-project.org/forums/viewthread/30414, namely I'm able to interact with the program by using mouse, but am unable to see the mouse-cursor (it is invisible)!

    I've tried to:

    provide -plugin evdevmouse argument to the application,

    compile the qt with additional arguments -qt-mouse-linuxinput - but that argument doesn't exist.

    2. Second problem is that applications don't have "titlebar" nor "minimize,maximize,close" buttons.

    I've tried to add this line in apps constructor (application compiles, but buttons don't appear):
    @setWindowFlags( Qt::WindowTitleHint | Qt::WindowMinMaxButtonsHint | Qt::WindowCloseButtonHint );@

    Does anyone know the solution to these problems? Any suggestion is helpful!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.