Win7 64bit with VS2010 and Qt 5.1.0 problem



  • I wanted to try Qt , so i did the following (which i read from the online documentation):

    Pc runs windows 7 Ultimate 64 bit and AVG antivirus.
    I installed Microsoft Visual Express 2010 and windows debugger tools
    then i installed Qt 5.1.0 (i also tried 5.1.1) for Vs2010 + Opengl.

    I setup debugger symbol path in a folder and choose the
    C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\cdb.exe for debbuger (also tried x86)

    -so far i want to believe i done nothing wrong-

    Then i start Qt, and choose to make a simple gui application.
    It opens .

    I choose Debug build , it compiles and then this error pops up

    !http://leposit.com/qt_problem.jpg(Qt problem)!

    If i click abort, it aborts and get me back to editor
    If i click retry , it crashes
    If i click ignore, it start :O

    I put the debug dlls in the folder of the .exe hoping for more clues and does the same.I even tried to comment out the qstring.h line that causes assert but nothing.

    Then i try the release build and starts with no errors. :O

    I tried to run the examples that comes with Qt but does the same. For some reason release build works but debugs cause error.

    I uninstalled,re-installed , rebooted, googled, tried to fix it but nothing helped me so far.

    If the compiler had an error it would not create the release version. So what is causing the error message.

    If there is a gap or huge error , in what i did please point it out , i dont mind getting laughed at , but i run out of ideas.

    Thanx in advance

    YG tried to google it and cant find any more clues, im guessing is someting so simple no1 even bothered to make a thread in forums


  • Moderators

    Hi,

    I notice that in your code, the line #include <QApplication> has a green line underneath it. The green line usually means Qt Creator can't find the header.

    However, since you still managed to compile the application, I suspect that your compiler is using different settings from what is set in Qt Creator.

    Anyway, Qt Creator should have auto-detected your copy of VS2010 and debugger if they are installed in their default locations; you shouldn't need to set up anything yourself. Try using the auto-detected kit.

    It is important to ensure that Visual Studio and Qt are not in your global PATH. If they are, remove them from your PATH. (This step ensures that your compiler and linker don't accidentally use the wrong version of a DLL, which can cause strange crashes like yours)

    Also, your project settings might be corrupted. Try deleting the whole project, and creating a new one using File -> New File or Project... -> Applications -> Qt Gui Application

    If you still have trouble, please provide screenshots of the following:

    • Tools -> Options -> Build & Run -> Compilers
    • Tools -> Options -> Build & Run -> Kits


  • thanx for taking time to read my problem.
    So
    1)i deleted all project (from the folder up)
    2)i made new simple gui application, and does the same
    3)took screenshot of what u asked

    !http://leposit.com/qt_problem2.jpg(qt problem goes on)!

    4)these are enviromental variables in path
    C:\Program Files (x86)\AMD APP\bin\x86_64;
    C:\Program Files (x86)\AMD APP\bin\x86;%SystemRoot%\system32;
    %SystemRoot%;
    %SystemRoot%\System32\Wbem;
    %SYSTEMROOT%\System32\WindowsPowerShell\v1.0;
    C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;
    C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn;
    C:\Program Files\Microsoft SQL Server\100\Tools\Binn;
    C:\Program Files\Microsoft SQL Server\100\DTS\Binn\

    5)weird thing is green underline went away ...


  • Moderators

    I've never seen this problem before, to be honest. Your PATH and compiler settings look correct.

    You have a 32-bit compiler but a 64-bit debugger though. I'm not sure if that works. Can you try with the x86 debugger again?

    Also, I remember that VS 2010 has a service pack for bug fixes, but users who want to upgrade it had problems. Do you need the Visual Studio IDE? If not, try this:

    Uninstall VS 2010

    Uninstall all copies of Microsoft Visual C++ Redistributable 2010

    Restart your computer

    Install "Windows SDK 7.1":http://www.microsoft.com/en-us/download/details.aspx?id=8442 -- it has the same compiler, but not the IDE

    Restart your computer

    Try debugging again



  • I did what u said and when i rebuilted it showed a new error :

    " Bad DLL or entry point ‘msobj80.dll’ "

    Googled it and tried these post
    http://qt-project.org/forums/viewthread/10009
    http://qt-project.org/forums/viewthread/19358

    the problem still occured (i done these in the past before trying ur help)...

    after uninstalling - reintalling , rebooting and retrying 2 times , can not reinstall windows sdk 7.1 or 8 anymore .... both appear to have problem installing (i managed to have exclusively one or another when i tried for the first time , but now i cant install any of em).

    i decide to give up. it shouldnt be that difficult to setup it in the first place , after all i just followed the instructions from the qt site when i initial tried it.

    I just wanted to make a small app , i ll just use visual basic, i ll be over soon

    thanx for trying to help

    YG in case qt people read this, if u make something that is intended to work with windows, try it first and make proper instructions so it can work out of the box or dont pretent at all that is working, its really annoying and discouraging


  • Moderators

    Hi,

    I'm sorry to hear that your experience has been frustrating.

    If you are willing to try one more time try installing "Qt 5.1.1 for Windows 32-bit - MinGW 4.8, OpenGL, 666 MB":http://download.qt-project.org/official_releases/qt/5.1/5.1.1/qt-windows-opensource-5.1.1-mingw48_opengl-x86-offline.exe. This is completely independent of Visual Studio, and contains a working compiler + debugger. It should work out-of-the-box without additional setup.

    From your descriptions, it looks like your Visual Studio installations have become corrupted (which could also have caused your original issue). msobj80.dll comes from VS 2008.

    If you need to install VS 2010/2012 (or Windows SDK 7.1/8) again, I recommend posting your installation error messages to the "MSDN forums":http://social.msdn.microsoft.com/Forums/en-US/home?forum=vssetup&filter=alltypes&sort=lastpostdesc.

    All the best with your app.



  • Well even though i will make my app in vb, i m still curious what is the problem with qt , so i tried the ming version (uninstalled previous version, reboot, installed new version).

    It doesnt pop the same error but new things (or the old with other names ?)

    here they are

    !http://leposit.com/qt3.jpg(qtqt)!

    !http://leposit.com/qt4.jpg(qtqt)!

    so no clue , if it isnt the microsoft compiler/debugger what is causing it to fail . (btw release works ok, just debug keeps crashing)


  • Moderators

    Hi,

    Why are you convinced that the problem is in Qt?

    Your Visual Studio/Windows SDK installations are corrupted. You need to clean all traces of VS 2010, VS 2012, Visual C++ Redistributable 2010, Visual C++ Redistributable 2012, Windows SDK 7.1, and Windows SDK 8 from your system (make sure all the files are removed, and all registry entries are gone). Then reboot. Then clean your project.

    Your last post shows that you have a "Visual C++" error (that means a Microsoft product). MinGW does not use Visual C++.



  • It just doesnt want to work on my computer, dunno what else to try , reached up to 5.0.0 qt version, did exactly what qt threads say, did what u said also but no result (even deleted the temp directory).

    Well i ve been trying and reading posts and seems many have problems with running qt. Trying diffirent things and getting diffrent errors every time.

    i wish qt made a tool for people to check compatibility of qt prior to installing it, or at least point to what is wrong.

    And i shouldnt been forced to uninstall whatever i have already installed so that qt could work, thats so wrong imo.

    YG i was working with qt at 2009 for 1 year and had no problems installing or compiling.Tho i was on windows xp 32bit and on a different computer.



  • Trying to bypass instead of fixing the error , i made (once more) clean install of the qt for ms vc 2010. Put debug dlls in exe folder of the debug build , then used dependency walker to see why it crashes...

    it seems that for some reason qtcored.dll imports functions from 2 windows dlls . At first dlls are x64 versions and so it crashes, when i put x32 version it crashes cause it cant find the functions.I found a thread for it in qt forums , i did what it said but my problem still exists.

    !http://leposit.com/qte/1.jpg(1)!

    !http://leposit.com/qte/2.jpg(1)!

    !http://leposit.com/qte/3.jpg(1)!

    !http://leposit.com/qte/4.jpg(1)!

    Is it possible for this to happen because i m using x86 qt in windows x64 ?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.