Requisites to enable GSteamer support



  • Hello,
    which are the requisites needed in order to enable the GStreamer support when compiling Qt5?

    I installed on the target device (RPi) the following packages:

    @
    libgstreamer0.10-dev
    libgstreamer-plugins-base0.10-dev
    gstreamer-tools
    gstreamer0.10-plugins-bad
    gstreamer0.10-plugins-good
    gstreamer0.10-plugins-ugly
    @

    and issued this configure command:

    @
    ./configure -opengl es2 -device linux-rasp-pi-g++ -device-option CROSS_COMPILE=~/dev/rpi/gcc-4.7-linaro-rpi-gnueabihf/bin/arm-linux-gnueabihf- -sysroot /mnt/rasp-pi-rootfs -opensource -confirm-license -optimized-qmake -reduce-relocations -reduce-exports -release -make libs -prefix /usr/local/qt5pi -no-pch -nomake examples -nomake tests -silent
    @

    Here the relevant output of the command:

    @
    Support enabled for:
    Accessibility .......... yes
    ALSA ................... no
    CUPS ................... no
    FontConfig ............. no
    FreeType ............... yes
    Iconv .................. yes
    ICU .................... no
    Image formats:
    GIF .................. yes (plugin, using system library)
    JPEG ................. yes (plugin, using bundled copy)
    PNG .................. yes (in QtGui, using bundled copy)
    Glib ................... no
    GStreamer .............. no
    @

    What am I missing?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.