Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QWebkit 4.8.5 on Mac OS X 10.7 (lion) can't play Flash..



  • I'm running a little low on ideas about how to run flash animations in Qt 4.8.5 on Mac OS X Lion. A simple snippet like the one that follows works smoothly both on windows and linux, loading the plugin and showing the relevant content just fine:

    @int main(int argc, char *argv[]) {
    QApplication app(argc, argv);
    QUrl url("http://www.adobe.com/software/flash/about");

    QWebSettings *defaultSettings = QWebSettings::globalSettings();
    defaultSettings->setAttribute(QWebSettings::JavascriptEnabled, true);
    defaultSettings->setAttribute(QWebSettings::PluginsEnabled, true);

    webview = new QWebView();
    webview->setGeometry(0,0,800,600);
    webview->load(url);
    webview->show();

    return app.exec();
    }@

    I tried pretty much everything and after a thorough research on this topic these are the steps I followed with no luck:

    • homebrew install (compiled OK as a 64bit binary, but flash won't play)
    • homebrew install -universal (compiling sadly failed)
      downloaded qt-everywhere-opensource-src-4.8.5 off digia and compiled as arch i386 since I read the flash plugin supposedly requires a patch to run as a 64bit library, even though there's NO issue whatsoever in chromium (not chorme) and safari (qt compiled and installed OK as a 32bit binary in /usr/local/Trolltech/Qt-4.8.5/, qmake worked great, but flash won't play)
    • tried several older flash plugins by removing and reinstalling the files in /Library/Internet Plug-Ins/ since you never know with flash... (didn't change a thing, no luck)
    • tried stripping the various versions of Flash Player.plugin of the x86_64 version with ditto --arch in order to show up just as a 32bit plugin (again, no luck)

    My question is: is there ANYBODY that was ever able to run flash animations with Qt 4 and QWebkit on Mac OS X? If so, would anybody care to share his exact steps?


Log in to reply