Packaging error in QtCreator 2.8 / Qt 5.1.1 for Android



  • When I try to build a default project or an example project with Qt 5.1.1 under Windows8 64bit it breaks at the packaging and deployment step.

    When I execute the deployment step seperately in QtCreator I get the following messages when I try to run it (with gcc 4.8 + 4.6):

    @12:47:04: Please wait, searching for a suitable device for target:android-15.
    Error while building/deploying project Android2 (kit: Android for arm (GCC 4.6, Qt 5.1.1))
    When executing step 'Deploy to Android device'@

    Under General Messages I see this:
    @Could not read qmake configuration file C:/Qt/Qt5.1.1-Android/5.1.1/android_armv7/mkspecs/android-g++/qmake.conf.
    Could not read qmake configuration file C:/Qt/Qt5.1.1-Android/5.1.1/android_x86/mkspecs/android-g++/qmake.conf.@

    Ant 1.9.2 and Java JDK 1.7.25 are installed and configured. I have a Samsung Galaxy S2 phone and therefore created an AVD with level15 & 4.0" for it, and compile with the ARM7 ABI.

    I've seen bug reports for this, but is there a quick fix I can apply right now instead of waiting 2-3 months for the next release?


  • Moderators

    what are the states of these bug reports?



  • Not exactly sure, because the comments are a bit confusing. But the changelog of QtCreatorv3 says that deployment issues have been fixed. But it doesn't say which ones...

    But there is no binary install to try it out :-/


  • Moderators

    please post the links to the bug reports.



  • Can't find them anymore, sorry. Maybe it was also another bug message that I had before this, which is also related to Ant.



  • A very simple thought which you may already tried - the emulator have to be started before you deploy the application.
    And the AVD have to be created via Android AVD Manager. There were some issues when creating AVD from the qt creator.



  • Yeah I tried to change the order of starting the emulator too. Didn't help. But I hope that the upcoming version Qt5.2 and more so QtCreator3 will have those bugs fixed.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.