WebKit build fail in 64bit Windows 7 and Qt 5.1.1 with mingw48_32



  • Hi...
    I am trying to build webkit in 64bit Windows 7 and Qt 5.1.1 with mingw48_32 but getting below errors from Qt Creator. I followed the instructions from here
    http://trac.webkit.org/wiki/BuildingQtOnWindows

    I am not getting the exact cause as I don't have much idea about configure the projects.
    It would be great if you could help me out.

    E:\Nirab\Qt\Workspace\WebKit-r156305\WebKit.pro:21: error: 'use?' is not a recognized test function.
    E:\Nirab\Qt\Workspace\WebKit-r156305\WebKit.pro:31: error: 'build?' is not a recognized test function.
    E:\Nirab\Qt\Workspace\WebKit-r156305\Source\JavaScriptCore\JavaScriptCore.pro:19: error: 'addStrictSubdirOrderBetween' is not a recognized test function.
    E:\Nirab\Qt\Workspace\WebKit-r156305\Source\JavaScriptCore\JavaScriptCore.pro:20: error: 'addStrictSubdirOrderBetween' is not a recognized test function.
    E:\Nirab\Qt\Workspace\WebKit-r156305\Source\WebCore\DerivedSources.pri:12: error: 'toSanitizedPath' is not a recognized replace function.
    ..........
    .........
    .........
    E:\Nirab\Qt\Workspace\WebKit-r156305\Source\api.pri:30: error: 'use?' is not a recognized test function.
    E:\Nirab\Qt\Workspace\WebKit-r156305\Source\api.pri:47: error: Cannot find feature webkit_modules
    :-1: error: Module does not define version.

    Thanks,
    -Nirab


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.