Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Trying to install 5.1



  • No factory found for qmake.exe


  • Lifetime Qt Champion

    Hi,

    Without more information, it will be difficult to help you



  • I was using 4.8 IDE, uninstalled it to install 5.0 (binaries)
    It installed ok (it runs etc), but there isn't any templates and qmake isn't auto detected etc.
    It does seem to install completely. I started this when 5.0 became available.



  • It looks like all the files are there.


  • Lifetime Qt Champion

    Then you need to add a new Qt version (the one you downloaded) and Kit to use it.

    Options -> Build & Run -> Qt versions
    Options -> Build & Run -> Kit



  • the Kit is fine, it auto-detected the mingw compiler.
    when manually tried to add the Qt version, it gives the above error.

    the templates are still missing etc.

    There is a InstallationLog text file that shows errors in it.



  • here are a few lines at the start and end of the log:

    Operations end: 16
    Resource count: 1
    Data block size: 684853205
    Magic marker: 302133811
    Magic cookie: 14007050384008702200
    Index size: 48
    End of data: 698447829
    Number of operations: 0
    StartMenuPath: "C:\Users\Owner\AppData\Roaming\Microsoft\Windows\Start Menu\Programs"
    DesktopDir: "C:\Users\Owner\Desktop"
    Unable to open translated license file. Using untranslated fallback.
    Unable to open translated license file. Using untranslated fallback.
    Unable to open translated license file. Using untranslated fallback.
    Unable to open translated license file. Using untranslated fallback.
    components list is empty in bool __thiscall QInstaller::PackageManagerCorePrivate::appendComponentsToUninstall(const class QList<class QInstaller::Component *> &)
    Tmp and install folder are on the same volume. Volume mount point: "C:" Free space available: "702.28 GiB"
    Installation space required: "3.25 GiB" Temporary space required: "908.92 MiB" Local repository size: "0.00 bytes"
    perform operation: Mkdir

    • arguments: C:/Qt
      Done
      backup operation: Mkdir
    • arguments: C:/Qt/Qt5.1.1
      Done
      perform operation: Mkdir
    • arguments: C:/Qt/Qt5.1.1
      Done
      Install size: 21 components
      Starting elevated process C:\Users\Owner\Downloads\qt-windows-opensource-5.1.1-mingw48_opengl-x86-offline.exe with arguments: --startserver 30863 {2a73c026-2257-4b62-8fc4-f16a35e8394f}.
      Finished starting elevated process.

    create Error-Exception: "Found a binary data file, but we are the installer and we should read the binary resource from our very own binary!"
    Operations start: 212687
    Operations end: 16
    Resource count: 1
    Data block size: 684853205
    Magic marker: 302133811
    Magic cookie: 14007050384008702200
    Index size: 48
    End of data: 698447829
    Writing uninstaller: "C:\Qt\Qt5.1.1/MaintenanceTool.exe.new"
    Maintenance tool restart: false.
    SHOW FINISHED PAGE
    run application as detached process: "C:\Qt\Qt5.1.1\Tools\QtCreator\bin\qtcreator.exe" () "C:/Users/Owner"


  • Lifetime Qt Champion

    What are the errors ?



  • create Error-Exception: “Found a binary data file, but we are the installer and we should read the binary resource from our very own binary!”



  • also,
    when i try to create a project the only templates available are for CMAKE non Qt projects.
    I want to use qmake


  • Lifetime Qt Champion

    That's normal if QtCreator can't find a valid Qt Kit. Anyway, did you try a newer installer ?



  • yes it is, but i downloaded it again.
    still the same problem.


  • Lifetime Qt Champion

    Strange, just installed the 5.1.1 MinGW Qt and no problem...



  • I noticed other little things weren't working, so i rebuilt my computer.
    So it is working now, BUT
    it shows keeps showing this in the application window:
    Key arival and hook
    every key stroke

    Thankyou for your help


  • Lifetime Qt Champion

    I don't understand the BUT part, could you post an image of the problem ?



  • Starting C:\Users\Charles\Documents\Qt Projects\build-MapleStory-Desktop_Qt_5_1_1_MinGW_32bit-Debug\debug\MapleStory.exe...
    Key arival and hookKey arival and hook


  • Lifetime Qt Champion

    Are you sure that these messages don't come from the application you are building ?



  • I don't thick so.
    It just a simple gui app, I haven't add any fancy stuff yet.



  • I was just wondering if you had an idea.
    I will keep hammering away at.


  • Lifetime Qt Champion

    From what you posted, it appears after you started your application. Does it also happen when you start an empty new GUI project ?



  • it happens when i make a entry in a text field.
    lineEdit, spinBox, etc.
    add each one of these in a blank gui app.


  • Lifetime Qt Champion

    Just tried it but I don't have anything coming on the output


Log in to reply