Qt5.1 osg3.2.0 Compiling osgtQt: Failed to find "glu32" in "".



  • I'm trying to compile the Qt-Library osgQt, because it's not provided in the precompiled packages (at least not for Windows 7(x64) and MSVS 11 - x64). Therefore I'm following these instructions:

    bq.

    1. Download osg 3.0.1 sources.
    2. Generate Visual Studio solution with CMake.
    3. Open OpenSceneGraph.sln in Visual studio
    4. Choose debug win32 (or other configuration you want)
    5. Select osgQt project
    6. From menu select Build, Build osgQt

    But I'm getting into trouble at the second step:

    When using CMake 2.8.11.2 I'm receiving the following error:

    @ CMake Error at D:/Programme/QT/5.1.0/msvc2012_64_opengl/lib/cmake/Qt5Gui/Qt5GuiConfigExtras.cmake:14 (message):
    Failed to find "glu32" in "".
    Call Stack (most recent call first):
    D:/Programme/QT/5.1.0/msvc2012_64_opengl/lib/cmake/Qt5Gui/Qt5GuiConfigExtras.cmake:48 (_qt5gui_find_extra_libs)
    D:/Programme/QT/5.1.0/msvc2012_64_opengl/lib/cmake/Qt5Gui/Qt5GuiConfig.cmake:127 (include)
    D:/Programme/QT/5.1.0/msvc2012_64_opengl/lib/cmake/Qt5Widgets/Qt5WidgetsConfig.cmake:83 (find_package)
    CMakeLists.txt:570 (FIND_PACKAGE)@

    Because many others had this problem before I followed this instruction
    (http://qt-project.org/forums/viewthread/30006/):

    bq. So it worked for me(at least the CMake coniguration, didnt try to actually use it in compilation yet).
    Steps to reproduce:
    bq.

    1. I used precompiled version of Qt 5.1(the one with OpenGL x64 for VS2012). To use it should be fine for you, as Qt 5.1 should support OpenGL3.2+ profiles out of the box, i dont think you need to use Glew anymore, just look at http://qt-project.org/doc/qt->5.1/qtgui/qabstractopenglfunctions.html hierarchy
    2. Installed Win SDK 8.0. But i think 7.0 could be fine.
    3. added
      set (CMAKE_PREFIX_PATH “C:\Program Files (x86)\Windows Kits\8.0\Lib\win8\um\x64”)
      line to my cmake file.
      That’s where glu32.lib and similar files are located.
    4. Run cmake-gui configure&generate, using VS 11 win64 as generator.

    It tried both (not during the same building process):

    @ set(CMAKE_PREFIX_PATH “D:\Programme\Microsoft SDKs\Windows\v7.0\Lib\x64”)
    set(CMAKE_PREFIX_PATH “C:\Program Files (x86)\Windows Kits\8.0\Lib\win8\um\x64”)@

    Does anybody has an idea how to fix this or if not a precompiled Version of osgQt for Qt 5.1 with osg 3.2.0 and MSVS2012 on Windows7(x64)?

    Thanks in advance.



  • I'm having the same issue. I'm trying to fix this issue on windows 8 seeing the exact same symptoms and other junk. If you have gotten over this already, please let me know, because I seriously need to get unblocked!

    http://www.qtcentre.org/threads/56185-cmake-error-with-Failed-to-find-quot-glu32-quot-in-quot-quot?p=251234#post251234



  • Solved:
    set (CMAKE_LIBRARY_PATH “C:\Program Files (x86)\Windows Kits\8.0\Lib\win8\um\x64”)



  • Thanks for that.



  • Doesn't fix it for me, I tried
    set (CMAKE_LIBRARY_PATH "C:\Program Files (x86)\Windows Kits\8.0\Lib\win8\um\x64")
    set (CMAKE_PREFIX_PATH "C:\Program Files (x86)\Windows Kits\8.0\Lib\win8\um\x64")
    set (CMAKE_MODULE_PATH "C:\Program Files (x86)\Windows Kits\8.0\Lib\win8\um\x64")

    Qt 5.3 beta OpenGL


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.