Problems with QT5 Addin for Visual Studio 2012



  • Hello,
    I have currently installed the QT5 addin for Visual Studio 2012 (Version 1.2.2). But when I want to compile the first project (e.g. the project which is created via the assistant when you want to start a new project), I get several errors:
    1>qtmaind.lib(qtmain_win.obj) : error LNK2038: Konflikt ermittelt für "_MSC_VER": Der Wert "1700" stimmt nicht mit dem Wert "1600" in moc_qttest.obj überein.
    1>qtmaind.lib(qtmain_win.obj) : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol ""__declspec(dllimport) void __cdecl std::_Xbad_alloc(void)" (_imp?_Xbad_alloc@std@@YAXXZ)" in Funktion ""char * __cdecl std::_Allocate<char>(unsigned int,char *)" (??$_Allocate@D@std@@YAPADIPAD@Z)".
    1>qtmaind.lib(qtmain_win.obj) : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol ""__declspec(dllimport) char const * __cdecl std::_Syserror_map(int)" (_imp?_Syserror_map@std@@YAPBDH@Z)" in Funktion ""public: virtual class std::error_condition __thiscall std::_System_error_category::default_error_condition(int)const " (?default_error_condition@_System_error_category@std@@UBE?AVerror_condition@2@H@Z)".
    1>qtmaind.lib(qtmain_win.obj) : error LNK2019: Verweis auf nicht aufgelöstes externes Symbol ""__declspec(dllimport) char const * __cdecl std::_Winerror_map(int)" (_imp?_Winerror_map@std@@YAPBDH@Z)" in Funktion ""public: virtual class std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> > __thiscall std::_System_error_category::message(int)const " (?message@_System_error_category@std@@UBE?AV?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@2@H@Z)".
    So, what are they telling me, and how can I fix them?
    Thank you very much!



  • error LNK2038: Konflikt ermittelt für “_MSC_VER”: Der Wert “1700” stimmt nicht mit dem Wert “1600”

    This means you are mixing the Visual Studio 2010 and 2012 compiler. Either your current project is compiled using the Visual Studio 2010 compiler and your Qt version with 2012 or vice versa.



  • I have installed VS2012 (no VS2010 found) and I am using QT 5.1.1 for VS2012, so I do not know why I am getting this error...


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.