N9 Meego Harmattan setup



  • Hi there, hopefully someone can help me with getting this setup,

    I've installed the 1.2.1 Qt SDK from Nokia using their offline installer and I only ever seem to have the following Build & Run targets:
    [I've tried running the SDKMaintenance Tool for Updates and it says none are available]

    Harmattan Target - QEmu PR 1.2 (Qt SDK) Debug
    Harmattan Target - QEmu PR 1.2 (Qt SDK) Release

    For each of the PR versions: 1.0, 1.1, 1.2

    These always try and deploy to the QEmu emulator when I run them, rather then the N9. My SDK Maintenance tool looks like this:

    http://imageshack.us/a/img18/2016/3a3e.jpg

    I have setup the N9 under the Linux Devices tab under the Options menu, I've installed the the keys to it and Qt Creator can read the Remote Processes list on the device just fine. I just can't seem to get Qt Creator to deploy to it, only the emulator.

    Is there another repository I am supposed to add to get a Harmattan target that isn't the emulator? I need to build and run on the N9 not QEmu.

    Thanks for any help.



  • It could well be a bug in Qt Creator.

    Perhaps you could have more luck with a later version of Qt Creator. I have Qt Creator 2.5.2 -- perhaps the last to work with Harmattan -- on top of Qt SDK 1.2.1 and it works fine.


  • Moderators

    I strongly recommend using the Qt Creator that comes with the Nokia Qt SDK. Any later version is untested with Harmattan targets AFAICT.

    In fact Qt Creator 3.0 has no more support for Harmattan as the trusted N9s of my co-workers are getting replaced with new hardware (mostly due to the hardware dying due to heavy use;-). People here really loved their N9s, but I unfortunately never managed to get one.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.