[SOLVED] Qt5.1.1 Creator Locals and Expressions empty on breakpoint?



  • Hi,

    I am using Ubuntu 10.04, and Qt5.1.1 with the stock creator (2.8.1). For some reason the local expressions table is completely empty when I have many variables on the stack. I've never had this issue in other version of Qt.

    Has anyone had this issue before and/or been able to fix it?

    Thank you!



  • I am having the same issue, if I find anything about this issue I will let you know. Have you found any additional information about this or resolved it?



  • I have not been able to fix this issue yet...its tough debugging an entire project without the local expressions window..

    My workaround currently is just to right click the expression I want to get a closer look at (variable), and add it to the watch window manually..



  • Hello

    I have a similar issue but I even can not right click.

    If you open the Debugger Log window you can see the debugger commands flow and see if there is any error.

    Best regards



  • I can't even add the values of C++ variables manually to the Locals and Expressions window, I used to be able to drag and drop them over before I upgraded. I can see Qml variables when I set a break point in a qml file but it won’t show me my c++ variables when I put a break point in my cpp files.



  • Anyone make any progress on this issue? I looked at the debugger log window, this is the only thing that throws a red flag to me as an error:

    @

    &"bb options:fancy,autoderef,dyntype vars: expanded:inspect,return,local,watch typeformats: formats: watchers:\n"
    ~"XXX: BLOCK NOT ACCESSIBLE FOR UNKNOWN REASONS\n"
    ~"\n"
    ~"data=[],typeinfo=[]\n"
    109^done
    dDISCARDING JUNK AT BEGIN OF RESPONSE: XXX: BLOCK NOT ACCESSIBLE FOR UNKNOWN REASONS
    d
    <Rebuild Watchmodel 3>
    @

    This is at the very end once I hit my breakpoint in the creator.



  • This is actually a GDB issue.

    I downloaded and installed the newest GDB from:
    ftp://sourceware.org/pub/gdb/releases/

    Make sure you install ncurses-dev before installing.

    For some reason, with the 'SDK' version of the Qt5.1.1 bundle, I wasn't able to change the location of the GDB under Tools->Options->Build & Run, So I downloaded the standalone QtCreator from Qt's website.

    Next, in your kit (by default) the GDB executable location is set to /usr/bin/

    The newest GDB is located (after installing) in /usr/local/bin/.

    Everything works now. Thank you.



  • I was able to get mine working (mostly) as well by updating gdb. Since I am working on embedded linux I downloaded the latest version from here: https://launchpad.net/linaro-toolchain-binaries


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.