(SOLVED)Qwt(qt) Application simpleplot not supproting Linux-devkit Environment in AM335x



  • Hi all,
    I am trying to build simpleplot example from qwt-6.1.0 in linux-devkit environment to download it into AM335x based device but it searching for one library file """"lqwt""""
    fle not found;
    @
    :-1: error: skipping incompatible /home/rnd4/Desktop/Praveen/tiqwt6.1.0/qwt-6.1.0/examples/../lib/libqwt.so when searching for -lqwt
    @

    while I am running the same Application on System Environment it running fine no issue:

    I dont understand why it searching for """lqwt""" in linux-devkit environment which is not require in system environment
    some where I read in QT EMBEDDED it search for """lqwtE """ if this file reqired then where i get this file because when i have installed qwt-6.1.0 ->lib->4 files (libqwt.so , libqwt.so.6 , libqwt.so.6.1 , libqwt.so.6.1.0 )
    I didn't find lqwt ;

    Praveen


  • Lifetime Qt Champion

    Hi,

    You have to cross-compile qwt before you can use it for your embedded needs.



  • Hi,
    you are so right we have to cross compile for embedded needs in linux-devkit environment that is avialable in ti-sdk-am335x-evm-05.07.00.00
    I rest of my Application i have cross compliled and downloaded in AM335x kit no issue.
    But in case of QWT it searching for library file lqwt :
    Is I have to install qwt in AM335x kit because it is not installed in AM335x kit if Yes How??

    While Cross Compliling i am taking care there should be
    necesssary files .

    should I have to mention some thing extra

    @
    QWT_ROOT = $$/home/rnd4/Desktop/Praveen/qwt-6.1.0/
    include(qwtconfig.pri )
    include(qwtbuild.pri )
    include(qwtfunctions.pri )
    TEMPLATE = app
    INCLUDEPATH += $${QWT_ROOT}/src
    DEPENDPATH += $${QWT_ROOT}/src
    !debug_and_release {
    DESTDIR = #same folder
    }
    else {
    CONFIG(debug, debug|release) {
    DESTDIR = #same folder
    }
    else {
    DESTDIR =
    }
    }
    QMAKE_RPATHDIR *= $${QWT_ROOT}/lib
    LIBS += -L$${QWT_ROOT}/lib
    qwtAddLibrary(qwt)
    greaterThan(QT_MAJOR_VERSION, 4) {
    QT += printsupport
    QT += concurrent
    }
    contains(QWT_CONFIG, QwtOpenGL ) {
    QT += opengl
    }
    else {
    DEFINES += QWT_NO_OPENGL
    }
    contains(QWT_CONFIG, QwtSvg) {

    QT += svg
    

    }
    else {
    DEFINES += QWT_NO_SVG
    }
    TARGET = deform
    SOURCES =
    simpleplot.cpp
    @
    Compling in linux-devkit env reqire
    pls reply soon

    Praveen


  • Lifetime Qt Champion

    Create you own build directory for qwt, in there use your cross-compiled Qt's qmake to configure the build and build.

    Then you can you use the generated lib from that directory to link to. You can also copy it in your sdk usr/local/lib folder (or equivalent, BUT NOT your system /usr/local/lib folder)

    Don't forget to copy it on your target.



  • As per your suggestion::

    I have made Directory-> deformqt6

    I have Included src and lib folder and changed the path of qwtbuild.pri and deform.pro and linked it to same directory -->deformqt6
    so in files in deformqt6 directory are :
    deform.pro lib(folder) src(folder) qwtbuild.pri qwtconfig.pri qwtfunctions.pri simpleplot.c
    Compling with Qt's qmake it is builded no issue and Makefile , simpleplot.o , deform object Created in same folder it is running no issue

    But to download the application i have compile with :

    ti-sdk-am335x-evm-05.07.00.00/linux-devkit/bin/qmake so that it will create the files eg: deform object and simpleplot.o file Makefile a/c to ti-sdk qmake

    but it is not creating showing the same error :

    Apart from that I have compile with terminal as Shown:

    @

    [linux-devkit]:~/DHAWAL/deformqt6> qmake -project
    [linux-devkit]:~/DHAWAL/deformqt6> qmake -unix CONFIG+=debug -nodepend -o Makefile deform.pro
    -unix is deprecated.
    [linux-devkit]:~/DHAWAL/deformqt6> make
    compiling simpleplot.cpp
    linking deform
    /home/rnd4/ti-sdk-am335x-evm-05.07.00.00/linux-devkit/bin/../lib/gcc/arm-arago-linux-gnueabi/4.5.3/../../../../arm-arago-linux-gnueabi/bin/ld: cannot find -lqwtE
    collect2: ld returned 1 exit status
    make: *** [deform] Error 1
    [linux-devkit]:~/DHAWAL/deformqt6>

    @

    let me compile first from ti-sdk qmake then I will create Directory on Target.

    if I am doing wrong pls suggest me:


  • Lifetime Qt Champion

    I didn't say anything about modifying any path for qwt



  • Sir,
    Changing path is never an issue in my case the Basic Problem is Compiling with Qt's qmake and Compiling with ti-skd's qmake
    whether I will go with the Application I made first or other both having same issue as i found new one....
    In modification I haven't did some different just provided the path of Lib and src(header files)

    but this """""""""""qwtl"""""""""" is still a problem for me.


  • Lifetime Qt Champion

    Then tell me exactly how you compile and cross-compile qwt (command line example is better)



  • Its very critical for me ; So I am moving to QCostoumPlot

    http://www.qcustomplot.com/index.php/tutorials/settingup

    from there I have downloaded ->run application -> In AM335x based Device its running perfectly Thank U for your support.

    Praveen


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.