QtCreator Mac gdb process taking longer than 40 seconds . . .



  • I have a 64-bit build of Qt 4.8.4 (built from source). I downloaded the prebuilt QtCreator (Based on Qt 4.8.4 (GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2336.9.00), 64 bit) ) I keep getting a gdb hang every time I try to debug.

    The Debugger log shows the following error

    CALL: SETUP INFERIOR
    <74-file-exec-and-symbols "/Users/karl/projects/filter1-build-Debug/filter1.app/Contents/MacOS/filter1"

    73^error,msg="Undefined command: \"python". Try "help"."

    UNEXPECTED GDB STDERR: Undefined command: "python". Try "help".

    I have my own version of python 2.7 installed but I have no idea why this error would show up.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Is your python in a special path ?

    If you can call it from your command line you can try to start QtCreator by using:

    @open myproject.pro@

    so Creator will use the environment from the command line.

    Hope it helps



  • This is a CMake based project so I don't have a .pro file. Obviously, if I try to do an open on the CMakeLists.txt file it just pops up a text editor.

    From a command window I did unset my PATH and reset it to just point at the obvious choices /bin:/usr/bin:/usr/sbin:/sbin and then tried doing an

    open /Application/Qt\ Creator.app

    and I still get the same result. Doing a "which python" points me to /usr/bin/python. This must be the system installed python 2.7.2.

    Any other hints?



  • BTW, I just built a simple .pro based project and doing an open on that gives me the same results. I wonder if the python error is a misleading symptom of some other problem . . .


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.