[solved]Changed id's for mac but after that the program quits unexpectedly.



  • I followed the suggestion given in this post :
    http://qt-project.org/forums/viewthread/24869

    my program shows @executable etc etc. and program opens and then quits unexpectedly.

    Please help me with this. I have seen the error log and there seems to be nothing there. What could be possible reason for this.

    update
    I tried to run the .app on other mac and error log showed following :

    Code Type: X86-64 (Native)
    Parent Process: launchd [102]

    Date/Time: 2013-08-30 19:08:50.788 +0530
    OS Version: Mac OS X 10.6.8 (10K549)
    Report Version: 6

    Interval Since Last Report: 8630180 sec
    Crashes Since Last Report: 45
    Per-App Crashes Since Last Report: 14
    Anonymous UUID: 44ECB2FC-4703-4698-A043-DDB8257DE9BA

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    Library not loaded: /Users/iphonedev/Qt5.0.2/5.0.2/clang_64/lib/QtGui.framework/Versions/5/QtGui
    Referenced from: /Users/pankaj/Desktop/aashit/myprograme.app/Contents/MacOS/../Frameworks/QtWidgets
    Reason: image not found

    even after changing the ids and path for dylib its still referring the old path of other pc.


  • Lifetime Qt Champion

    Hi,

    Did you update the Qt libraries id ?



  • Sir I have done two things :

    1. Change the id of the libraries.
    2. Modify paths in executable.

    As given in deploy for mac documentation.
    [I will try this process once more and let you know if the problem persists.



  • macdeployqt worked like a charm did not needed to change any id etc.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.