Qt Creator missing menus after some uninstall/install processes



  • I installed the Qt 5.1 package which comes with QtCreator 2.7.2. Then I tried to update it to version 2.8, but it came "incomplete", missing a lot of menus. Now, after I tried installing/reinstalling a lot of times from both the Online and Offline packages, Qt Creator will always have an incomplete interface. See the pictures below for what I mean by incomplete:
    http://tinypic.com/r/xda4cw/5
    http://tinypic.com/r/x2rxjo/5
    http://tinypic.com/r/2vtp9ja/5

    The only way I could manage to install a working version was directly from "apt-get", which installed an older version, using Qt4.8, but I need Qt5.1.

    Coud someone please help me on this one?
    Thanks in advance,
    Lgb.



  • Looks like a lot of modules have not been loaded. You can check what Creator thinks is available. It pretty much looks like some library mixup, perhaps something pulls in something incompatible from elsewhere in the system.

    (Oh, and Qt 5.1.1 with Creator 2.8.1 has just been released)



  • Hi, andrep, thank you for your reply!
    I hadn't noticed that Qt 5.1.1 had been launched, I have just downloaded it.
    However, I'm still not able to fix that problem with Qt Creator. Could anyone please help to fix this? Should I install Qt and Qt Creator under a specific path, or something like that?



  • Ok, so I just managed to fix it. I uninstalled everything related to Qt in "apt-get", delete all the configuration related to it in .conf (Nokia.conf, Trolltech.conf, Qt.conf QtCreator folder, etc) and installed the new Qt 5.1.1 bundle.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.