New Widget does not show up



  • I've set up a screen for my application some time back and was working on some other stuff. When I came back to it, I wanted to add a new label to the screen so I dragged it on to the form using the designer. However, when I run the application the label does not appear on the screen. The same is true for other widgets I've dragged onto the form, they don't appear when I run the app.

    Why can't I see the label?

    Regards,

    [using Creator 2.8.0 on Ubuntu with Qt 4.6.3]



  • I had the same time of issue a while back using QT5.0.2, Where I would add a new tab to my tab widget or and action in the form designer, but the changes wouldn't appear when I would try to debug/run my application.

    I ended up opening the ui header and making all my changes there.

    It seems like there might be an issue with QT creator translating the .ui files.

    I hope this helps



  • Thanks Buckets, I'm at least glad that someone else can see the problem!



  • Wait a minute!
    When I click Edit to try to edit the .ui file, it tells me "This file can only be edited in Design mode". When I click on Switch Mode, it takes me back into the Designer (which I can edit but the edits don't show up when I run/debug)!



  • The ui file I was altering wasn't the form_name.ui but the header contained the same project directory called ui_form_name.h this is a file QT creates when you are using the designer to create a form.

    I added the existing file to my project and ended up scraping the form_name.ui.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.