Set up Qt creator for Tizen on Ubuntu



  • Hi all,
    I used the tizenbuildtools from "Git":https://gitorious.org/tizenbuildtools to build Qt for Tizen emulator and its done. So far so good. Now i configured tizen specific qmake on Qt creator to build for Tizen emulator.

    I also need to deploy the Qt application on the Tizen emulator [already available]. How can i invoke and deploy application on Tizen emulator from using the Qt creator. I have found one document here "Qt creator for Tizen analysis":http://qt-project.org/wiki/Qt-Creator-for-Tizen-Analysis. But i was unable to understand the procedures mentioned there.
    Is there anyone who has tried building apps for Tizen using Qt creator?



  • Hi Arun, "Qt creator for Tizen analysis" is our design document, not a HOWTO. Qt Creator integration is a work in progress and once functional, instructions will be published. Please expect that in September :)

    For further questions please look at the Contact info at the top of http://qt-project.org/wiki/Tizen.

    Best Regards.



  • Hi all,

        I want to install Qt for tizen. I followed the steps given in http://qt-project.org/wiki/Build-Qt-for-Tizen. I am using ubuntu 12.04 on 32 bit for tizen emulator. while configuring Qt creator, I couldn't find Tools -> Options, and in the dialog “Tizen” item. I downloaded & tried with Qt-creator-2.8.0, 2.8.1 & 3.0.0. But nowhere found Tizen item in options of dialog.
    
       Please help...


  • Are your sure you didn't miss the "Build Tizen plugin for Qt Creator" step?

    See http://qt-project.org/wiki/Build-Qt-for-Tizen#00b2d759558c279641a474b3190dc4c3

    do you have
    $QTCREATOR_INSTALL_DIR/lib/qtcreator/plugins/QtProject/libTizen.so
    file?

    If not then it looks like the Tizen plugin was not built.



  • When I run this command : QTC_BUILD=$HOME/qtcreator-2.8.1 ./build_and_deploy_tizen_plugin.sh, I am getting like : Submodule 'qtcreator/plugins/tizen' () registered for path 'qtcreator/plugins/tizen'. How I can find out, which is the QTCREATOR_INSTALL_DIR ?



  • Well, I got that directory. Now i am getting like: qmake Qt version (4.8.1) is not compatible with Qt used by Qt creator(5.2.0).
    How i can upgrade qmake 4.8.1 to 5.2.0 ?



  • QTCREATOR_INSTALL_DIR=$HOME/qtcreator-2.8.1
    in your case.
    regarding:
    "qmake Qt version (4.8.1) is not compatible with Qt used by Qt creator(5.2.0)"
    You are trying to build plugin for QtCreator 3.0 which is not handled yet. Just use QtCreator 2.8.*
    After running ./build_and_deploy_tizen_plugin.sh you should have libTizen.so in your:
    $HOME/qtcreator-2.8.1/lib/qtcreator/plugins/QtProject/



  • No, I tried with qtcreator-2.8.82 as below:
    This is my command : QTC_BUILD=/opt/qtcreator-2.8.82 ./build_and_deploy_tizen_plugin.sh
    I got,
    Submodule 'qtcreator/plugins/tizen' () registered for path 'qtcreator/plugins/tizen'
    qmake Qt version (4.8.1) is not compatible with Qt used by Qt creator(5.2.0)



  • Qt Creator 2.8.82 is in fact QtCreator 3.0. You can try to install e.g. QtCreator 2.8.1 and it should work. I'm currently working on QtCreator 3.0 integration. I plan to release it by the end of next week.



  • Ok, When i run: ~/qtcreator-2.8.1/ ./build_and_deploy_tizen_plugin.sh
    I am getting make error like:
    In file included from tizenplugin.h:33:0,
    from tizenplugin.cpp:30:
    sdbconnector.h:36:22: fatal error: QTcpSocket: No such file or directory
    #include <QTcpSocket>
    ^
    compilation terminated.
    make: *** [.obj/release-shared/tizenplugin.o] Error 1



  • it looks like you lack QtNetwork development files in your Qt installation. If you use system qmake then install libqt4-network (at least this is how it is named in my 13.10).



  • Well thank you, Now its working. but when i open qtcreator i ll get error mesage like:
    qtcreator-2.8.1/lib/qtcreator/plugins/Nokia/libTizen.so: The shared library was not found.
    Is this shared library is necessary or shall i ignore that library?



  • Probably you end up with 2.8.82 sources in:
    tizenbuildtools/qtcreator/qt-creator-sources

    just remove tizenbuildtools/qtcreator/qt-creator-sources
    and try to rebuild again. It looks like the plugin didn't build successfully.



  • Thank you. I don't know how to create and run an application. I tried as follows.
    create project -> applications -> Qt quick 2 applications (chose), name, finish. after run, I am getting like:
    [install_itemfolder_01] Error 1




Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.