Unknow MinGw version



  • I all guy and thanks in advance.

    I would like to download and install qt library, I have codeblock 12:11 and I downloaded the package with MinGw compiler. Than I downloaded qt 4.8 version but during the install, selecting the mingw path, I obtain an error because my mingw version is newer than qt4 need. I don't know how determine wich version of mingw I have. Can you help me suggesting the right qt version to download?? I need the package for both win 32 and 64 bit.

    Sorry for my english.

    Thanks a lot.



  • bq. I obtain an error because my mingw version is newer than qt4 need.

    Well you can ignore this and continue using Qt4 with newer MinGw.
    To know MinGw version installed use @g++ --version@


  • Moderators

    Hi,

    See the last post at http://qt-project.org/forums/viewthread/21079

    [quote author="Santosh Reddy" date="1377315566"][quote]I obtain an error because my mingw version is newer than qt4 need.[/quote]

    Well you can ignore this and continue using Qt4 with newer MinGw.[/quote]Not quite.

    The official supported version is MinGW 4.4. People have reported that MinGW 4.5 and 4.6 work too, but MinGW 4.7 and 4.8 will definitely crash your compiled program.



  • mmmm It's little bit frustrating...
    I have the 4.7.1 version.. Than I have Uninstall entirely code::blocks (or just the mingw package if is it possible but I should it isn't) and reinstall code::blocks with a OLD version of the compiler?????

    I'm little bit surprised about this.

    isn't there a version of qt who works fine with gcc 4.7.1??

    Thanks a lot


  • Moderators

    You can build Qt 4.8.x yourself with the newer MinGW compilers. Here is the "wiki entry":http://qt-project.org/wiki/Building_Qt_Desktop_for_Windows_with_MinGW describing the procedure. I have done this begin of year for 32 and 64 bit compilers and updated the wiki entry. The default builds are typically not problem. It is more the waiting until the compilation is finished.



  • Yes I have read your post, thanks all guys for yours support. I think i will install a previous version of mingw.

    Thanks



  • I manually created a 4.6.1 version of mingw compiler downloading and unzipping all the files written on the official site tutorial. The compiler works fine.. now I tried to install qt4.

    Thanks for your support


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.