QtWayland + Qt5.0.2 + Wayland 1.0.4: Trying to get it working on Fedora17

  • Hello All --

    I'm trying to get QtWayland working on an embedded system based on Fedora17. It has Qt5.0.2 and Wayland/Weston 1.0.4. Unfort. updating either is not an option at this point in time.

    If I try working with current branch of QtWayland:
    git clone git://gitorious.org/qt/qtwayland.git

    and I perform a qmake I get:
    Project ERROR: QtWayland requires Wayland 1.1.0 or higher

    If I try working with an older branch of QtWayland:
    git clone git://gitorious.org/qt/qtwayland qtwayland-0.85 -b 0.85

    qmake succeeds, but the gmake fails with:
    Project ERROR: PLUGIN_TYPE (plugins/ subdirectory) needs to be defined.

    Is there a way to fix my issue with the QtWayland 0.85 branch? (E.g., by setting an environment variable, etc.)

    Or is there a another tag I should be using, or commit point on stable, that I should be using to get QtWayland working with Qt5.0.2 and Wayland 1.0.4?

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.