Problem to compile qmake.exe : incompatible x64 error (Win8 x64, VS 2010 x64 tools SP1)

  • Hi everybody,

    I'm trying to compile "Realxtend project ": (if possible in x64 but x32 is fine too). So this project have a script for automatic configure/download/compile successively all tools. I initialy installed TortoiseHG, Mysys Git, Tortoise SVN, MS Visual Studio 2010 (ultimate) with x64 tools and SP1 and Windows SDK v8, then it compile OpenSSL and Qmake in 32 or even 64 (i think, i'm a beginner in compilation but it's one week i'm on that). But after qmake don't want run and compilation of all project failed. Then i try launch only generated qmake.exe in cmd prompt, it says this program isn't compatible with my 64 bits Win version... that is my huge problem.

    And i try too the regular installation of Qmake (in c:\qt...) on Qt Project website, with minimum of dependencies i hoped, but i have the same error. My complete console message is in "this link ": if needed with two errors at the ends "not found" LNK1104 and NMAKE U1077 0x450 . I already asked help to realxtend devs but we are stuck on this and it seems specific to qmake.exe and its compilation, why this spot. Thx for reading (and more for answering) !1

    _Edit 1 :_I install too Win SDK 7.1 in parallel, let the default install path, but it's for Win7 only i think, SDK version corresponding with Win version used that i understand, anyway the error is still there. And I write almost the same post on "Stackflow":, it's maybe more understandable and it would be usefull to cross answers if there are.

  • What Qt download did you install on your machine? Are you sure you downloaded the VS2010 / 64 bit installer?

  • Also, if you compile from a command window, make sure its the "Microsoft Visual Studio 2010->Visual Studio Tools->Visual Studio x64 Win64 Command Prompt" one, as only that will compile and link in 64 bit mode. And run a 'nmake clean' to make sure you have no 32 bit object files lurking around.

  • Hi KelthS, so for Qt version, the script download qt-everywhere-opensource-src-4.8.5 zipped version and compile as open source version automatically (see paste bin link in first post for config and process). Then, yes i use "VS Cmd Prompt x64" of Microsoft Visual Studio 2010 Ultimate with "x64 tools and compiler" option installed too ( what I mean by VS 2010 / 64 bit installation).

    So, i tried 'nmake -clean' cmd but it saied it didn't find 'MAKEFILE'. And now, even trying in Win7 x64 (dual-boot), it failed with exactly the same error. This is my path variables, is it here something miss (Perl always before other tools to work) ?

    C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common
    C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x86
    C:\Program Files (x86)\Intel\OpenCL SDK\3.0\bin\x64
    C:\Program Files\TortoiseSVN\bin
    C:\Program Files\TortoiseHg
    C:\Program Files (x86)\Git\cmd
    C:\Program Files (x86)\CMake 2.8\bin
    C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn
    C:\Program Files\Microsoft SQL Server\100\Tools\Binn
    C:\Program Files\Microsoft SQL Server\100\DTS\Binn\

  • Lifetime Qt Champion


    What is puzzling is that qmake doesn't get linked. Do you have any other Qt installed on your machine ?

  • Hi SGalst ! On Win7, i installed realxtend project properly for compilation so i don't have other Qt installed or even uninstalled.

    However, i ran 'nmake -clean' in '...\qt\qmake' folder and now it's work better. Thanks KelthS ! There is normally no need to do that with the automated script, but I do... So for 'nmake' is OK. Then comes a problem with 'jom' but there is an option to not use it : USE_JOM = TRUE to FALSE and now the compilation continues (which takes about 5 hours) ! When all work on Win7, i will retry this on Win8.

Log in to reply