[SOLVED]Entry method not found in QtCore4.dll after compiling



  • Hi,

    I just compiled Qt4.8 with the latest MinGW (the same that I use for compiling my Qt+Ogre program). The application is compiling fine but when I launch it, I have the message telling that the entry point of the method
    ?cap@QRegExp@@QAE?AVQString@@H@Z is unreachable in the QtCore4.dll library. Here is the original french message:

    Le point d'entrée de procédure ?cap@QRegExp@@QAE?AVQString@@H@Z est introuvable dans la bibliothèque de liaisons dynamique QtCore4.dll

    I used the .dll stored in qt-everywhere.../bin/. I copied this dll in the same directory as my application.
    I had the same message when I used the prebuilt version of Qt4.8.

    I know this topic exist already but I did all that was mentionned (compiled Qt with the same MinGW used for compiling the application, copy the right dll (?)). By the way, I have matlab directory in my PATH with QtCore.dll. Is the PATH taken in prior than the current directory?

    Many thanks in advance!



  • My bad, I forgot to copy QtXML4.dll in the correct folder, so I guess it takes ones there's somwhere in the PATH variable and this dll try to call an incorrect method.

    I apologize, problem solved.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    great you found out and shared the solution. Could you also update the thread's title to solved ? So other forum users may know that a solution has been found :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.