Qt Creator 2.8 with MinGW4.8 can't debug??



  • Why I tried to debug my code and set breakpoint, the Qt Creator always show

    "This does not seem to be a "Debug" build.
    Setting breakpoints by file name and line number may fail."

    I checked my setting in the project is Debug and Debugger in my Kit is ..\mingw48_32\bin\gdb.exe
    What's wrong with this!? Does anybody know. Thanks in advance.


  • Moderators

    At least older versions of Qt creator did show but continued to compile and run release versions.
    Did you try to rerun qmake and rebuild on the project ?



  • Yes, I tried. It still can't work.



  • Make sure that you select the right type of build.
    !http://s7.postimg.org/f7i2hfokr/Untitled.png(build conf)!
    Мassege:
    "This does not seem to be a “Debug” build.
    Setting breakpoints by file name and line number may fail."
    is displayed only if you try debug in release mode.


  • Lifetime Qt Champion

    Hi,

    Are you sure you are building with a debug version of Qt ?



  • Yes, I am very sure.Actually, I have two versions of Qt Creator, because when I downloaded "Qt 5.1.0 for Windows 32-bit (MinGW 4.8, OpenGL, 666 MB) (Info)" from download page, then I installed, I found Qt Creator is 2.7.2. Everything can work well on it. Next, I downloaded Qt Creator 2.8, I found I can't debug anything, I have tried to find what happened about it, but unfortunately I couldn't successful. I checked "Debugger Log" and I found something is different between two version of Qt Creator, but I still couldn't solve this problem.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.