VS Compiler and Qt Creator



  • I'm fairly new at this and am encountering a problem. I've been using Visual Studio Express and Visual Studio Professional (trial) but I don't know how to link their compiler(s) to Qt Creator. I've programmed in C++ before, it being my main language, I only had some trouble setting up Qt.

    @:-1: error: Qt Creator needs a compiler set up to build. Configure a compiler in the kit options.@

    [EDIT]: Thank you, qzox, for the edited title of this thread.



  • Hi pars99.
    Welcome to devnet.
    First of all you need change title of thread, for example:
    "Set compiler for QtCreator " or "VS compiler and QtCreator" or other more relevant to question title.
    And about your question. What version of Qt you have install?
    Take a look to this "doc":http://doc.qt.digia.com/qtcreator-2.1/creator-project-qmake.html


  • Moderators

    [quote author="qxoz" date="1374607392"]Take a look to this "doc":http://doc.qt.digia.com/qtcreator-2.1/creator-project-qmake.html[/quote]That documentation is far too old; Qt Creator has changed to a new kit system now.

    pars99, you need to perform two steps:

    "Set up your compiler":http://qt-project.org/doc/qtcreator-2.8/creator-tool-chains.html, and then

    "Set up your kit":http://qt-project.org/doc/qtcreator-2.8/creator-targets.html

    [quote author="qxoz" date="1374607392"]And about your question. What version of Qt you have install? [/quote]Yes, this is important. Which package did you download?



  • bq. Yes, this is important. What package did you download?

    I downloaded Qt version 5.1, MinGW (32-bit). Though I did recently download VS Studio Express 2012 and VS Studio Professional (TRIAL)...

    bq. First of all you need change title of thread, for example:
    “Set compiler for QtCreator “ or “VS compiler and QtCreator” or other more relevant to question title.

    Okay, thank you. I will try to make my post titles more relevant next time. I have visited a number of forums and have realized that people won't usually view my post and/or answer it when I post the specifics. That's why I titled it so broadly.


  • Moderators

    [quote author="pars99" date="1374636683"]I downloaded Qt version 5.1, MinGW (32-bit). Though I did recently download VS Studio Express 2012 and VS Studio Professional (TRIAL)...[/quote]If you downloaded the MinGW package, then you'll need to use the MinGW compiler -- the binary files are incompatible with Visual Studio's compiler. Make sure you asked the installer to install MinGW too.

    By the way, VS Express and VS professional use the same compiler -- the difference between them is that Professional provides a more powerful IDE.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.