Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

Why is my Creator 2.8 using an older QT of 4.8 than my Creator 2.7?



  • I upgraded Creator but did not upgrade my QT Kit. Creator 2.8 shows its About "Based on QT 4.8". The slightly older Creator 2.7 however shows based on QT 5.1.

    Why would this be? I did not download anything other than the 5.1 SDK, which came with Creator 2.7x. I installed only an upgrade to Creator, nothing else, and it shows an older kit in its About.


  • Moderators

    The "about" box shows the version of Qt that was used to compile Qt Creator (Qt Creator is a standalone application, just like one of your own projects). That version of Qt is completely unrelated to your kit.

    Anyway, it doesn't affect developers -- Whether it was compiled with Qt 4.8 or Qt 5.1, Qt Creator's functionality remains the same.


Log in to reply