Failed to build QtWebKit in Qt5.1.0 on Windows



  • I build the qt base from source qt-everywhere-opensource-src-5.1.0 successfully, and qtwebkit does not build. I don't known how to build qtwebkit.

    I try to generate visual studio project file, it got the error message:

    E:\qt-everywhere-opensource-src-5.1.0\qtwebkit>e:\qt-everywhere-opensource-src-5
    .1.0\qtbase\bin\qmake -spec win32-msvc2010 -tp vc "WebKit.pro" -recursive QMAKE_
    INCDIR_QT=$(QTDIR)\include QMAKE_LIBDIR=$(QTDIR)\lib QMAKE_MOC=$(QTDIR)\bin\moc.
    exe QMAKE_QMAKE=$(QTDIR)\bin\qmake.exe
    'pkg-config' is not recognized as an internal or external command,
    operable program or batch file.
    'pkg-config' is not recognized as an internal or external command,
    operable program or batch file.
    'pkg-config' is not recognized as an internal or external command,
    operable program or batch file.
    'pkg-config' is not recognized as an internal or external command,
    operable program or batch file.
    Reading E:/qt-everywhere-opensource-src-5.1.0/qtwebkit/Source/WTF/WTF.pro
    Reading E:/qt-everywhere-opensource-src-5.1.0/qtwebkit/Source/JavaScriptCore/Jav
    aScriptCore.pro
    Project ERROR: Strict subdir dependencies can only be used with subdirs template



  • Hello ~netcaf

    Welcome to Qt Developer Network

    There is only one library, which you never never never should build on the Windows. It's called WebKit. Building QtWebKit requires to build WebKit on the background, though.

    I can't help you, and I guess, not me only but everybody here. Sorry



  • I'm getting that same error now. People are building Qt with Webkit so there must be a way of getting it to work!



  • [quote author="mkrus" date="1374145656"]I'm getting that same error now. People are building Qt with Webkit so there must be a way of getting it to work![/quote]

    I am pretty sure that people have a lot of problems with it and I can't even imagine, why do you need to build Qt, strictly with WebKit.



  • because we use QtWebKit to display map data on a GoogleMap view!



  • [quote author="mkrus" date="1374149576"]because we use QtWebKit to display map data on a GoogleMap view![/quote]

    Why do you need to BUILD Qt? Why can't you use prebuilt binaries?



  • because Qt (or Digia) don't provide VS2010 64 bit builds. And no I'm not updating my 25-or-so libraries to VS2012 this month (or year for that matter)



  • [quote author="mkrus" date="1374158062"]because Qt (or Digia) don't provide VS2010 64 bit builds. And no I'm not updating my 25-or-so libraries to VS2012 this month (or year for that matter)[/quote]

    Sure, they don't. Everybody knows that it's better to use Qt Creator to develop Qt applications. Anyway, I can't help you with that



  • I do use Qt Creator, that has nothing to do with it!
    And they do VS2010 32bit builds, and VS2012 64bits. Just not 64bits VS2010...



  • You can try the following below from a previous post to see if that option helps you build webkit.

    @OK finally managed to do a 5.1 Alpha shadow build. The biggest issue that was causing webkit not to build was a missing path to gnuwin32\bin inside the source tree. Adding that manually makes things work.

    set PATH=C:\Qt\5.1-a\src\gnuwin32;%PATH%
    

    My config:

    ..\src\configure -icu -mp -nomake tests -nomake demos -nomake examples -openssl -angle -I C:\Qt\5.1-a\icu-w32\include -I C:/Qt/5.1-a/openssl-1.0.1c-x86/inc32 -L C:/Qt/5.1-a/icu-w32\lib -L C:/Qt/5.1-a/openssl-1.0.1c-x86/out32dll -prefix [PERCENT]CD[PERCENT]\qtbase -opensource -platform win32-msvc2010
    

    (replace [percent] with the actual percent character, it’s messing up the post)

    You’ll get a qmldeclarative related error for a not-found module. Simply go into qtdeclarative/src/qmldevtools and type

    nmake release
    

    Go back up and continue the build. If you built with ICU you also manually need to place the ICU libraries into the qtbase\bin directory.

    After all that you’ll end up with a fully built release.
    @

    from "http://qt-project.org/forums/viewthread/26565":http://qt-project.org/forums/viewthread/26565




  • Moderators

    [quote author="netcaf" date="1373852841"]
    'pkg-config' is not recognized as an internal or external command,
    operable program or batch file.[/quote]Your system is complaining that it can't find pkg-config, so you need to add the gnuwin32 folder (which also contains a few other required tools) to your PATH as shown in gametack's post.

    Also, remember to install ICU, Ruby, Python and Perl.

    You might find some other useful information at http://qt-project.org/wiki/Building_Qt_5_from_Git

    [quote author="tucnak" date="1373996146"]
    There is only one library, which you never never never should build on the Windows. It's called WebKit. Building QtWebKit requires to build WebKit on the background, though.

    I can't help you, and I guess, not me only but everybody here. Sorry[/quote]Tucnak, if you can't help, let someone else do so instead of making discouraging remarks. There are plenty of people who have successfully built WebKit on Windows, who can help netcaf. Your post was useless and unhelpful.



  • Hi

    got the same fix, put everything I found together in a "script":https://gist.github.com/mkrus/6030102 which does the downloading, configuring, building and installing...

    Thanks for everyone's help!


  • Moderators

    [quote author="mkrus" date="1374225398"]Hi

    got the same fix, put everything I found together in a "script":https://gist.github.com/mkrus/6030102 which does the downloading, configuring, building and installing...

    Thanks for everyone's help![/quote]Glad to hear :) Thank you for sharing your script!



  • Hi,

    I encountered difficulties to build QtWebKit, and I found your post. Is your script working with version 5.1.1? I tried to use it (by replacing jom by nmake) and it seems that it contains two errors:

    • According to VS command prompt shortcut, I guess it's amd64 instead of x64 in this line : "C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\vcvarsall.bat" -x64- amd64
    • I guess a "s" is missing in configure line (for no making tests) . ... -nomake tests ...

    I checked several times that I have all the prerequisites (tools + environment variables) but QtWebkit never built. :-S (my environment is Windows 7 64bit with Visual Studio 2010)

    Do you have any suggestions?

    Regards,
    Jonathan



  • Re,

    I recreated my build script from scratch and install ActivePerl instead of Strawberry Perl, and now build is completly done.

    Below the main commands of my script:
    @
    configure -prefix %FINAL_DIST_DIR% -opensource -confirm-license -openssl -plugin-sql-mysql -debug-and-release -nomake tests -nomake examples -skip quick1 -skip multimedia -skip serialport -skip sensors -skip qtwebkit-examples -platform win32-msvc2010 -mp

    nmake
    nmake clean | nmake install
    @

    I suggest to use -mp to enable mutlithread build (time gain).

    Once again, thanks to mkrus for his script.
    Regards,
    Jonathan


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.