Problems with Open-Source Downloads read https://www.qt.io/blog/problem-with-open-source-downloads and https://forum.qt.io/post/638946

[Solve]QT 5.1 Deployment on mac OS X, how could I deploy the QtQuick2 apps?



  • How could I let the app know where to find the dylib?

    I create the folder inside of the bundle

    @
    mkdir qmlTest2.app/Contents/PlugIns
    mkdir qmlTest2.app/Contents/PlugIns/QtQuick
    mkdir qmlTest2.app/Contents/PlugIns/QtQuick/Controls@

    use install_name_tool to change the id and dependencies of the "libqtquickcontrolsplugin.dylib"
    but the app always complain it can't find the QtQuick component

    My qt.conf is
    @
    [Paths]
    Plugins = PlugIns
    @

    Do I need to add something into the qt.conf?the plugins
    under "/Users/name/Qt5.1.0/5.1.0/clang_64/qml" can't find by the app

    The whole procedures of my deployment steps are

    1 : copy the dll of "qml/QtQuick/Controls" to "Contents/PlugIns/QtQuick/Controls"

    2 : run the script on stackoverflow "workaround":http://stackoverflow.com/questions/17475788/qt-5-1-and-mac-bug-making-macdeployqt-not-working-properly.Thanks to JimmyTaker

    3 : run macdeployqt

    4 : execute the app by lldb

    Then I get the error message,

    bq. file:///Users/Qt/program/experiment_apps_and_libs/qmlTest2/main.qml:23:1: module "QtQuick" is not installed
    import QtQuick 2.1

    I can find the QtQuick module when I run otool -L, so I guess the problem maybe is on the plugins

    @executable_path/../Frameworks/QtQuick.framework/Versions/5/QtQuick@

    The qml is very simple

    @
    import QtQuick 2.1

    Rectangle{
    width: 400
    height: 300
    color: "black"
    }
    @

    ps : Some say the macdeploy of Qt5.1rc don't have bug like Qt5.1, I tried it but it do not work either
    looks like macdeploy can't deploy the QtQuick apps yet



  • Any document could show us how to deploy QtQuick2 apps on mac?
    Which plugins we must have?Where are they?

    I am staring at a blank white screen with no information on what I am doing wrong.
    It is highly frustrating!

    my .pro

    @
    QT += core gui qml quick

    CONFIG += c++11

    SOURCES +=
    main.cpp

    OTHER_FILES +=
    main.qml

    @




Log in to reply