[Bug] Advanced search does not return any results



  • I just created a thread for a topic that had been discussed previously so I decided to double check why I didn't find it first.

    I tried an "Advanced search" with these parameters:

    Search by Keyword: group e-mail
    Search in titles and posts
    Search for any word
    Search in forums: Beta Testing

    Odd enough it did not return any results when I have created a thread called ""The confirmation e-mail accepting group has html tags but is plain text":http://developer.qt.nokia.com/forums/viewthread/2979".

    What did I miss?

    p.s. If I search for just "e-mail" or "group" it does work???



  • Hum, I'm not able to reproduce, I get 1 result and that is the thread you link to.

    Maybe someone else could give it a go and verify?



  • this search returns exacly this thread, but not the other onw, even when I search the whole forum. Perhaps that's because the group is in some quotes?:

    The confirmation e-mail “accepting a group” has html tags but is plain text.



  • Hah, Gerolf is much smarter than me, I vote for his theory.



  • I tried and it only returned this topic. Indeed weird :-/



  • If it are the quotes, wouldn't it be bug? Cause then all quoted words will be ignored and the quoted words might be the more interesting ones to search for, right?



  • [quote author="mariusg" date="1294156627"]Hah, Gerolf is much smarter than me, I vote for his theory.[/quote]

    I cannot second that. I just removed the quotes for a test and the search still does not return the thread. (I've re-added the quotes).



  • Very odd.... If I search by just clicking on "advanced search" on the right side of this page and ONLY add "e-mail group" (without the quotation marks) I don't get any results at all!



  • It was just a guess :-)
    or it seraches the multiple words only in text and not in the header. If you search for each word sepetrately, it finds the thread.

    EDIT: this is also just a guess....



  • OK.... It is even stranger.... I repeated the process but now got one result... I can't figure out what I may have done different the first time when I didn't get any....

    Also, the most important part is that even if you select "search for any word" it only returns the same ONE result. I would imagine that would return all the results for the "e-mail" search PLUS all results for the "group" search. Shouldn't it?



  • One more piece of the puzzle: I removed the quotation marks from the thread title and still isn't included on the search results.

    Do we have any lag before the "page" gets indexed?



  • The page is indexed, as it is found when you search for only one of the words. I think it's more of the thing searching in the title vs. searching in the body.

    It seams that searching multiple words in a title does only work, if the words appear in the same order with no other words in between.

    I tested the following:

    Search by Keyword: Advanced search
    Search in titles
    Search for any word
    Search in forums: All

    and it returned this page. If I search for:

    Search by Keyword: Advanced does

    it returns nothing...



  • [quote author="Gerolf" date="1294157884"]EDIT: this is also just a guess....[/quote]
    :-D


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.