Qt World Summit: Submit your Presentation

QtQuick 2 and Android emulator

  • I tried to deploy QtQuick2 application to an Android virtual device(Android-16) but it shows nothing on the screen, just white screen. MouseArea works good, but I don't see anything. I tried to use gpu=on, but no result.

    Is it possible to test QML apps using Android Emulator?

  • No, this stuff does not work as far as I know. I also dislike the android emulator. It also fails at running opengl ES 2 apps.

    I will try genymotion(new androvm) and report back if this works :P

  • Thanks :) I didn't know about genymotion.

  • I have tried genymotion, but the app doesn't work there at all.
    It can't load lib--Managed_by_Qt_Creator--plugins_platforms_libqminimal.so: open failed: ENOENT (No such file or directory). But this plugin is present in the apk package.

  • I tried it, too. Had some issues starting the virtual machines, only one of them works though. Anyways, the app stays black like on the android emulator. Thats bad.

    Real devices work fine

  • bq. app stays black

    Yup and if you look at the DDMS log you can see that it is because of lib-Managed_by_Qt_Creator—plugins_platforms_libqminimal.so

  • It switches on every restart of the app for me. Probably it just shows the first library it does not find :P
    But you are right, actually those libs are in the apk. I dont know what the emulator is doing then

Log in to reply