Qt execvp: permission denied

  • I'm using Qt4 and Qt Creator on Ubuntu 13.10. I want to debug directly on the Beaglebone hardware. With the simplest Qt GUI application with just a pushbutton on the UI, I get the error below. It compiles OK for the desktop build. CAn anyone tell me whats causing this?

    @10:40:28: Running steps for project testqt2...
    10:40:28: Starting: "/usr/local/angstrom/arm/bin/qmake" /home/user/QTProjects/testqt2/testqt2/testqt2.pro -r -spec /usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/share/qtopia/mkspecs/linux-g++
    10:40:28: The process "/usr/local/angstrom/arm/bin/qmake" exited normally.
    10:40:28: Starting: "/usr/bin/make"
    ../testqt2/mainwindow.ui -o ui_mainwindow.h
    make: execvp: ../testqt2/mainwindow.ui: Permission denied
    make: *** [ui_mainwindow.h] Error 127
    10:40:28: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project testqt2 (kit: BeagleBone)
    When executing step 'Make'
    10:40:28: Elapsed time: 00:00.@

    There is a red exclaimation mark beside the Beaglebone kit, when I hover over it, it says:
    @Error:Mkspec not found for Qt version@

    In Projects, Build Settings the Build Settings are:
    @Build Directory = /home/user/QTProjects/testqt2/build-testqt2-BeagleBone-Release
    Effective qmake call=qmake /home/user/QTProjects/testqt2/testqt2/testqt2.pro -r -spec /usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/share/qtopia/mkspecs/linux-g++
    make in= /home/user/QTProjects/testqt2/build-testqt2-Beaglebone-Release@

    In Projects, Build Settings the Run Settings are:
    @files to deploy-files path=/home/user/QTProjects/testqt2/build-testqt2-BeagleBone-Release/testqt2Remote directory=/home/root
    Run configuration arguments=-qws
    System Environment Variable=QWS_MOUSE_PROTO
    System Environment Value=LinuxInput:/dev/input/event0@

    In Manage kits, the remote device is set up correctly and I can test it:
    @Connecting to host...
    Checking kernel version...
    Linux 3.2.42-psp27 armv7l

    Checking if specified ports are available...
    All specified ports are available.

    Device test finished successfully.@

    Beaglebone Kit:
    @Compiler path=/usr/local/angstrom/arm/bin/arm-angstrom-linux-gnueabi-g++
    debugger path=usr/local/angstrom/arm/bin/arm-angstrom-linux-gnueabi-gdb
    Qt mkspec=/usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/share/qtopia/mkspecs/linux-g++
    Qt version=Qt 4.6.3 (arm)@

  • make: execvp: ../testqt2/mainwindow.ui: Permission denied

    may be you used "uic" binary compiled for x86?

  • I do not know what you mean by "uic".

    What I do know is that I am using the Arm cross compiler and it cross-compiles OK from a terminal window.


  • Hi, I've solved that issues.... here my solution.

    You must to add, the environment variables that corresponding at BBB Toolchain. in Qt creator, Projects tab, build option , in Build Environment section.

    add this..

    Set OE_QMAKE_UIC3 to /usr/local/angstrom/arm/bin/uic34
    Set PATH to $SDK_PATH/bin:$PATH
    Set PKG_CONFIG_PATH to $SDK_PATH/$TARGET_SYS/usr/lib/pkgconfig
    Set QMAKESPEC to /usr/local/angstrom/arm/arm-angstrom-linux-gnueabi//usr/share/qtopia/mkspecs/linux-g++
    Set SDK_PATH to /usr/local/angstrom/arm
    Set TARGET_SYS to arm-angstrom-linux-gnueabi
    Set alias opkg to "LD_LIBRARY_PATH=$SDK_PATH/lib $SDK_PATH/bin/opkg-cl -f $SDK_PATH//etc/opkg-sdk.conf -o $SDK_PATH"
    Set alias opkg-target to "LD_LIBRARY_PATH=$SDK_PATH/lib $SDK_PATH/bin/opkg-cl -f $SDK_PATH/$TARGET_SYS/etc/opkg.c


Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.