Ld: error: cannot find -lQt5Designer



  • Hi, I am trying to compile qt5 from git. Apart from navigating my filesystem, I have done this:

    git clone git://gitorious.org/qt/qt5.git qt5

    perl init-repository

    ./configure -developer-build -xplatform android-g++ -nomake tests -nomake examples -android-ndk $ANDROID_NDK -android-sdk $ANDROID_SDK -android-ndk-host linux-x86_64 -skip qttranslations -skip qtwebkit -skip qtserialport -skip qtwebkit-examples

    make clean

    make

    The tail of my output: see line 4
    @
    make[4]: Entering directory /mnt/Dropbox/qt5/qtquick1/src/plugins/qdeclarativeview' rm -f libqdeclarativeview.so /home/joel/Program/android-ndk/toolchains/arm-linux-androideabi-4.7/prebuilt/linux-x86_64/bin/arm-linux-androideabi-g++ --sysroot=/home/joel/Program/android-ndk/platforms/android-9/arch-arm/ -Wl,--no-undefined -Wl,-rpath=/mnt/Dropbox/qt5/qtbase/lib -Wl,-rpath-link=/mnt/Dropbox/qt5/qtbase/lib -Wl,--no-undefined -Wl,-z,noexecstack -shared -o libqdeclarativeview.so .obj/debug-shared/qdeclarativeview_plugin.o .obj/debug-shared/moc_qdeclarativeview_plugin.o -L/home/joel/Program/android-ndk/sources/cxx-stl/gnu-libstdc++/4.7/libs/armeabi-v7a -L/home/joel/Program/android-ndk/platforms/android-9/arch-arm//usr/lib -L/mnt/Dropbox/qt5/qtbase/lib -lQt5Designer -lQt5Declarative -lQt5XmlPatterns -lQt5Network -lQt5Sql -lQt5Widgets -lQt5Xml -lQt5Script -lQt5Gui -lQt5Core -lgnustl_shared -lsupc++ -llog -lz -lm -ldl -lc -lgcc -lGLESv2 /mnt/Dropbox/Program/android-ndk/toolchains/arm-linux-androideabi-4.7/prebuilt/linux-x86_64/bin/../lib/gcc/arm-linux-androideabi/4.7/../../../../arm-linux-androideabi/bin/ld: error: cannot find -lQt5Designer collect2: error: ld returned 1 exit status make[4]: *** [/mnt/Dropbox/qt5/qtbase/plugins/designer/libqdeclarativeview.so] Error 1 make[4]: Leaving directory/mnt/Dropbox/qt5/qtquick1/src/plugins/qdeclarativeview'
    make[3]: *** [sub-qdeclarativeview-make_first] Error 2
    make[3]: Leaving directory /mnt/Dropbox/qt5/qtquick1/src/plugins' make[2]: *** [sub-plugins-make_first-ordered] Error 2 make[2]: Leaving directory/mnt/Dropbox/qt5/qtquick1/src'
    make[1]: *** [sub-src-make_first] Error 2
    make[1]: Leaving directory `/mnt/Dropbox/qt5/qtquick1'
    make: *** [module-qtquick1-make_first] Error 2
    @



  • go to /qtquick1/src/plugins/qdeclarativeview open Makefile, find and delete -lQt5Designer, save it and run make again....

    if you don't have Makefile, rerun configure with -fully-process



  • Hi,
    I have the same issue.
    Is this solution correct ? Isn't it required to use Qt5Designer ?

    Regards,
    Ran


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.