[Solved] Qt 5.1 RC1 Install



  • Hi,

    I just had recently made a fresh install on Ubuntu, so i decided to install Qt 5.1 RC1.
    But after sucessfull installation when i try to run code that previously was working on Qt 5.1 Beta before i had to reinstall Ubuntu, i get the following error:

    • :-1: error: cannot find -lGL

    • :-1: error: collect2: ld returned 1 exit status

    I had first installed gcc using:

    • sudo apt-get install build-essential

    and:

    • sudo apt-get install mesa-common-dev

    What am i missing?

    Thanks


  • Moderators

    See a list of dependencies here: "link":http://qt-project.org/doc/qt-5.0/qtdoc/requirements-x11.html.



  • Thanks.
    I didn't build it using source code, i downloaded the qt-linux-opensource-5.1.0-rc1-x86-offline.run

    So, all should be installed, or so i think...

    But i get the error i mentioned in my previous post, but i don't know to which dependencie is related to and how to install it.


  • Moderators

    This package installs only Qt libraries and Qt Creator IDE. You have to provide dependencies yourself. The error you are getting is about missing OpenGL stuff. See the list I've linked, below the table there is a list off all Debian packages you need to install using - for example - apt-get.



  • I already did:
    sudo apt-get install ... for all those dependencies:

    • libfontconfig1-dev
      
    • libfreetype6-dev
      
    • libx11-dev
      
    • libxext-dev
      
    • libxfixes-dev
      
    • libxi-dev
      
    • libxrender-dev
      
    • libxcb1-dev
      
    • libx11-xcb-dev
      
    • libxcb-glx0-dev
      

    and also for:

    • libxcb-keysyms1-dev
      
    • libxcb-image0-dev
      
    • libxcb-shm0-dev
      
    • libxcb-icccm4-dev
      
    • libxcb-sync0-dev
      
    • libxcb-xfixes0-dev
      
    • libxcb-shape0-dev
      
    • libxcb-randr0-dev
      
    • libxcb-render-util0-dev

    But i'm getting the same error, nothing changed.
    Do i need to install something else ou make some changes in Qt configuration?


  • Moderators

    You have missed:
    @
    sudo apt-get install libglu1-mesa-dev
    @



  • Thanks.
    It's now working.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.