Building Qt 5.1.0-rc1 for TI DVSDK DM365 4.02.00.06



  • Hello!

    I am trying to build Qt 5.1.0-rc1 for TI DVSDK DM365 4.02.00.06 environment:

    1. Linux ubuntu 2.6.32-38-generic #83-Ubuntu SMP Wed Jan 4 11:13:04 UTC 2012 i686 GNU/Linux
    2. export $DVSDK = /home/artem/ti-dvsdk_dm365-evm_4_02_00_06
    3. qt-everywhere-opensource-src-5.1.0-rc1.tar.gz
    4. /home/artem/SDK/qt-5.1.0-rc1/qtbase/mkspecs/linux-arm-gnueabi-g++/qmake.conf
      @

    qmake configuration for building with arm-linux-gnueabi-g++

    MAKEFILE_GENERATOR = UNIX
    CONFIG += incremental gdb_dwarf_index
    QMAKE_INCREMENTAL_STYLE = sublib

    include(../common/linux.conf)
    include(../common/gcc-base-unix.conf)
    include(../common/g++-unix.conf)

    modifications to g++.conf

    QMAKE_CC = /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-gcc
    QMAKE_CXX = /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-g++
    QMAKE_LINK = /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-g++
    QMAKE_LINK_SHLIB = /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-g++

    modifications to linux.conf

    QMAKE_AR = /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-ar cqs
    QMAKE_OBJCOPY = /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-objcopy
    QMAKE_STRIP = /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-strip

    load(qt_config)
    @

    1. My configure is
      @
      ./configure -prefix /home/artem/SDK/qt-5.1.0-rc1/qtbase -verbose -opensource -confirm-license -continue -no-cups -no-accessibility -no-sm -no-nis -qt-libjpeg -qt-libpng -qt-zlib -no-sql-ibase -no-sql-mysql -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 -no-pch -no-dbus -no-glib -no-opengl -no-gui -no-openssl -no-largefile -no-audio-backend -optimized-qmake -nomake examples -nomake demos -nomake docs -nomake translations -release -static -platform linux-arm-gnueabi-g++
      @

    I do not use "source ${DVSDK}/linux-devkit/environment-setup" but configure builds qmake with "arm-none-linux-gnueabi-g++" compiler:
    @
    /home/artem/CodeSourcery/Sourcery_G++_Lite/bin/arm-none-linux-gnueabi-g++ -c -o qlocale_unix.o -pipe -O2 -g -DQMAKE_OPENSOURCE_EDITION -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/qmake -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/qmake/library -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/qmake/generators -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/qmake/generators/unix -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/qmake/generators/win32 -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/qmake/generators/mac -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/qmake/generators/integrity -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/include -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/include/QtCore -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/include/QtCore/5.1.0 -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/include/QtCore/5.1.0/QtCore -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/src/corelib/global -DHAVE_QCONFIG_CPP -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/mkspecs/linux-arm-gnueabi-g++ -I/home/artem/SDK/qt-5.1.0-rc1/qtbase/tools/shared -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DPROEVALUATOR_FULL -DPROEVALUATOR_DEBUG -DQT_NO_TEXTCODEC -DQT_NO_UNICODETABLES -DQT_NO_COMPONENT -DQT_NO_COMPRESS -DQT_NO_THREAD -DQT_NO_QOBJECT -DQT_NO_GEOM_VARIANT -DQT_NO_DATASTREAM /home/artem/SDK/qt-5.1.0-rc1/qtbase/src/corelib/tools/qlocale_unix.cpp
    @

    And then tries to start it:
    @
    Running configuration tests...
    Failed to process makespec for platform 'linux-arm-gnueabi-g++'
    /home/artem/SDK/qt-5.1.0-rc1/qtbase/configure: line 4090: /home/artem/SDK/qt-5.1.0-rc1/qtbase/bin/qmake: cannot execute binary file
    *** qtbase/configure exited with non-zero status.
    @

    Please help me start host "g++" compiler for qmake! What configure parameter do I miss?



  • Changing configure parameter to:
    @-xplatform /home/artem/SDK/qt-5.1.0-rc1/qtbase/mkspecs/linux-arm-gnueabi-g++@

    makes it possible to build qmake with "g++" compiler. But the rest Qt 5.1.0 SDK builds with "g++" compiler also... What is wrong?



  • To whom it may consern.

    Configure parameters are:

    ./configure -prefix /home/artem/SDK/qt-5.1.0/qtbase -opensource -confirm-license -continue -no-cups -no-accessibility -no-sm -no-nis -qt-libjpeg -qt-libpng -qt-zlib -no-sql-ibase -no-sql-mysql -no-sql-odbc -no-sql-psql -no-sql-sqlite -no-sql-sqlite2 -no-pch -no-dbus -no-glib -no-opengl -no-gui -no-icu -no-javascript-jit -openssl-linked -no-largefile -no-qml-debug -no-audio-backend -optimized-qmake -nomake examples -nomake demos -nomake docs -nomake translations -nomake tests -skip webkit -skip declarative -release -static -no-c++11 -xplatform /home/artem/SDK/qt-5.1.0/qtbase/mkspecs/linux-arm-gnueabi-g++ -v



  • I had the same problem when cross compiling for my Xilinx Zynq Board. My problem was that my toolchain had a softlink from g++ to armv7l-unknown-linux-gnueabihf-g++. To fix the problem I had to was to add the crosscompile/bin folder to the end of $PATH instead of at the beginning.

    Use the following command to test which g++ is called.
    @which g++@



  • I had the same problem when cross compiling for my Xilinx Zynq Board. My problem was that my toolchain had a softlink from g++ to armv7l-unknown-linux-gnueabihf-g++. To fix the problem I had to was to add the crosscompile/bin folder to the end of $PATH instead of at the beginning.

    Use the following command to test which g++ is called.
    @which g++@


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.