Unresponsive QTreeView On OSX But not on windows



  • Hello,

    Hopefully my descriptive title says it all. I have a Qt app that has worked perfectly on Windows for a few months now, but a few days ago I ported it to OSX. This worked okay. The app works with no errors, memory leaks or other undesirable things.

    However there are some problems on OSX. Keeping in mind that the code is identical on both platforms. The QTreeView is unresponsive when clicked on. After you click on it once it has a light blue border around it. After this it is unresponsive to clicks until another QTreeView is clicked on (Same thing happens with another one) then click back again. Then it gets its blue border and becomes unresponsive.

    I haven't even a clue where to start looking for a solution.

    On another note of porting to OSX. My app also has two QGLWidgets. Which work, until you pop there window out of the main application window. When you do the GLWidget seems to disappear and leave an empty window, until you pop it back in again, and it returns to its normal state.

    There are no errors being thrown and it works perfectly on Windows so I have not got a clue what is wrong.

    Using Qt 5.0.2

    David


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.