[Solved] Qt4 Software Deployment in RHEL4_U7 64bit



  • I succeeded in building Qt4 source in Fedora13 64bit
    And copied executable and libraries from fedora13 into RHEL4_U7.

    @
    ldd sample_exe
    linux-vdso.so.1 => (0x00007fff5afff000)
    libQtXml.so.4 => /home/shint/qtsdk-2010.05/qt/lib/libQtXml.so.4 (0x00007f7829d6c000)
    libQtOpenGL.so.4 => /home/shint/qtsdk-2010.05/qt/lib/libQtOpenGL.so.4 (0x00007f7829a7a000)
    libQtGui.so.4 => /home/shint/qtsdk-2010.05/qt/lib/libQtGui.so.4 (0x00007f7828cd5000)
    libQtCore.so.4 => /home/shint/qtsdk-2010.05/qt/lib/libQtCore.so.4 (0x00007f78287f2000)
    libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x00007f7828593000)
    libGL.so.1 => /usr/lib64/libGL.so.1 (0x00007f7828327000)
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f782810b000)
    libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00007f7827e04000)
    libm.so.6 => /lib64/libm.so.6 (0x00007f7827b80000)
    libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f782796a000)
    libc.so.6 => /lib64/libc.so.6 (0x00007f78275eb000)
    libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00007f782734f000)
    libdl.so.2 => /lib64/libdl.so.2 (0x00007f782714b000)
    libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00007f7826f41000)
    libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00007f7826d0b000)
    libz.so.1 => /lib64/libz.so.1 (0x00007f7826af6000)
    libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007f78268e4000)
    libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007f78265a5000)
    libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00007f78263a1000)
    librt.so.1 => /lib64/librt.so.1 (0x00007f7826199000)
    libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00007f7825e9d000)
    libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00007f7825c57000)
    libSM.so.6 => /usr/lib64/libSM.so.6 (0x00007f7825a4f000)
    libICE.so.6 => /usr/lib64/libICE.so.6 (0x00007f7825833000)
    libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x00007f782562e000)
    libXdamage.so.1 => /usr/lib64/libXdamage.so.1 (0x00007f782542c000)
    libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00007f7825227000)
    libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00007f782501c000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f7829fb8000)
    libexpat.so.1 => /lib64/libexpat.so.1 (0x00007f7824df4000)
    libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007f7824bd9000)
    libuuid.so.1 => /lib64/libuuid.so.1 (0x00007f78249d5000)
    libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007f78247d2000)
    @

    the error message in RHEL4_U7 is as follows:
    @
    ldd sample_exe
    not a dynamic executable
    @

    the error message in RHEL4_U7 is as follows:
    @
    ./sample_exe
    ./sample_exe: error while loading shared libraries: requires glibc 2.5 or later dynamic linker
    @

    the error message in RHEL4_U7 is as follows:
    @
    /lib/ld-2.3.4.so ./sample_exe
    ./sample_exe: error while loading shared libraries: ./sample_exe: cannot open shared object file: No such file or directory
    @

    I hope somebody could help me.

    [EDIT: fixed @-tags for code, Volker]



  • glibc in RHEL is too old. Try upgrading RHEL (latest version is 6). Besides Qt should be in repository (try sudo yum install qt or yum search qt).



  • maciek. you're answer. thank you.
    but. we can not upgrade the system. that is not our system.

    i solved.
    Qt libraries 4.7.1 for Linux/X11(202 MB) - download and static compiled.

    follow this. [ RHEL4_U7 64bit ]
    cd [userfolder] // <-- path is don't use 2Byte language and space
    wget http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.7.1.tar.gz
    tar xvfz qt-everywhere-opensource-src-4.7.1.tar.gz
    cd qt-everywhere-opensource-src-4.7.1
    ./configure -static
    make sub-src
    make install // <-- if occured error. do not be surprised.

    mkdir /usr/local/Trolltech
    mv qt-everywhere-opensource-src-4.7.1 /usr/local/Trolltech/Qt-4.7.1

    and.
    cd [qt projectfolder]
    xxx.pro // <-- edit this .pro file
    CONFIG += static // <-- if you want static compile.

    /usr/local/Trolltech/Qt-4.7.1/bin/qmake *.pro
    make clean
    /usr/local/Trolltech/Qt-4.7.1/bin/qmake -config release
    make



  • Since its solved, please change the post title to indicate [solved] status.



  • ok.
    i changed title.



  • [quote author="shint" date="1293768213"]ok.
    i changed title.
    [/quote]

    Thank you


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.